Broadlink broken with 115

you have to use a combination of both is my understanding. set up the integration as per instructions. Then add switch config to config.yaml. Note that both host and type are missing from the config.yaml as they are now included via the integration e.g.

  - platform: broadlink
#    host:
    mac: <your broadlink mac>
#    type: rm4_mini
              friendly_name: "Soundbar Toggle"
              command_on: '<incomprehensible string of magic>'
              command_off: '<incomprehensible string of magic>'

Hope that helps?

I am not sure if others are experiencing this, but I noticed that after I upgraded to 115, my Broadlink RM Mini 3 is rebooting itself all the time, it stays on maybe 1-2 minutes, and then it reboots again. I can see it from my routers client list, that it has not stayed online more than 2 minutes, then suddenly it’s at 0 minutes online again… And since it reboots itself constantly, I cannot use it all (no commands go through from Home Assistant, as it sees that the device is offline. Update 115.1 did not help with this :confused:

1 Like

I have to connect sp3, not remote.
So I do not have “magic strings”

I write just in case it can help someone else with my problem. I have a thermostat fluoreon component based on broadlink, and until I deactivated it too from configuration.yaml the integration via ui failed. So you have to deactivate all components that have a reference to the broadlink, restart, configure via ui and then reactivate the various components .

This component is also not working for me, I removed all mentions of the old broadlink from my configuration. I install the integration, give it the IP address and it brings up the Chinese name, which I change but I get no devices or entities configured. Here is what I do see after I restart homeassistant:

2020-09-18 21:03:02 ERROR (MainThread) [homeassistant.config_entries] Error setting up entry br-rm4pro for broadlink
  File "/usr/src/homeassistant/homeassistant/components/broadlink/", line 28, in async_setup_entry
  File "/usr/src/homeassistant/homeassistant/components/broadlink/", line 97, in async_setup
  File "/usr/src/homeassistant/homeassistant/components/broadlink/", line 24, in get_update_manager

It did work in the old method where I could specify that I had a rm4pro. I think the device is coming back as unknown and I have noticed using other tools that my rm4pro has a different device id: 0x649b

I edited the file /usr/local/lib/python3.8/site-packages/broadlink/ and added an entry for my broadlink id, this fixed the issue. I saw a change being made to the broadlink python code to add it so later releases should pick it up.

From the link you have provided, it states the smart plugs will automatically be created. What Broadlink device are you using?

The switch entities allow you to control and monitor Broadlink smart plugs, power strips and switches.
You can turn them on and off, and you can monitor their state and power consumption, when available.
These entities are created automatically when you configure a device that has switches.

same issue here, RM mini 3, setup the integration, updated the config, but my switches are showing “entity not available”

There is a an update 0.115.1. This is suppose to fix the rm3 issue. Updating as I am writing. Hope to get it working.

I just updated to 0.115.1, still the same

I finally managed to solve the issues.
The main idea is to not use yaml configuration at all.
Read carefully the information on Release Notes. Sroll to “Breaking Changes/broadlink” section.
It looks like the broadlink integration is going to be controlled via UI, not yaml.

The only yaml configuration is used to create virtual switches to send IR commands.

yep, I didn’t notice the subtle change in the switches yaml

I had the exact codes you had before the update. After the update, a handful of IR codes did not show up in HA. I, then, redid the code as per their breaking changes. All good now.


pretty sure you have to change the config for switches

check the docs

Can I be the first that would ask how to use Broadlink anyway? 0.115 was the first time it appeared in my HA. Is there a UK YouView setup anyone can share?

I finally got all my Broadlink devices working again after updating to 0.115.1. This is what I did.
Note: I have the RM4 Pro and RM3 Mini devices. I believe this quick update was a patch fix for the RM3 Mini. The RM4 Pro works on Ver. 0.115.
If these steps do not work for you, you may have a device that isn’t supported yet. Best to check this open issue and see if they have added your device type or include yours to the list.

– Delete any previous Broadlink devices you have troubled with if the integration failed.
– Make sure you have your IR codes in a switch.yaml file in this new format.
– Update HA to 0.115.1 if you haven’t done so and restart Ha.
– After reboot, if HA does not auto discover your Broadlink devices…
– Navigate to configuration -> integrations -> click on orange + sign. Search for Broadlink
– Type the ip address of your device for HOST. Name your device and it should install a remote entity by default and any other sensors you have for Broadlink automatically.
– If you have included your IR codes in a switch.yaml before the device setup, you should see your IR codes in the frontend.
– Repeat the steps to add more devices if you have more than one.

1 Like

I’ve tried the steps above, updated the switch to the new format, but it is still not showing up in the integration, no entities. Any ideas?

Is your device either the rm4 or the rm3 mini?

After installing version 115.1 I have the similar issue. I have configured Broadlink integration, it seems OK. I have some custom switches, so I modified the configuration.yaml as mentioned above. The config check is OK, but after restarting the home assistant the switches are not shown in the user interface. An example from my configuration.yaml:

  - platform: broadlink
    mac: !secret broadlinkmac
      - name: Hálószoba

Could you please check it.

It’s Broadlink RM Pro+. It was fine running under 114. Been scratching my hairs off. Hope i don’t get bald over this :joy: My missy has been bugging me to fix it.

This guide should get you started.