Broadlink Config

Hi there,

Sorry of this topic was already created. I am new and i dont know any coding.
I have google home, alexa, broadlink tc2 with rm3 pro, ikea tradfri and hue lights.

I can not add broadlink to home assistant. can anybody help me to add broadlink rm3 and tc2 swithes?
Thank youj

Got my Broadlink RMmini3 yesterday and just followed the documentation for the component here:

The only issue I had was that my model wasn’t explicitly shown in the documentation but a quick search on this forum helped me sort that out, too.
Not even sure, if the definition for the tpye: is strictly required for my model, though. Didn’t try without it.

And here is what I’m using now:

  - platform: broadlink
    host: 192.168.7.XX
    mac: '11:22:33:44:55:66'
    type:  rm_mini
    friendly_name: Universal Remote
    timeout: 15
        friendly_name: "Soundbar Power"
        command_on: 'togglecode'
        command_off: 'togglecode'

Hope that helps!

Thank you so much!. Just one question: where do we find the comment on and off codes?

Again, searching this forum I found a link to:

Worked great for my RMmini3 and my ‘dumb’ Samsung TV.

Still trying to find codes for my Samsung Soundbar, though.
I have captured many according to the instructions, but I wonder if there are separate codes e.g. for power_on and power_off as well, just like they seem to exist for my Samsung TV (rather than just being able to toggle power on/off).

What you’re looking for are called ‘discrete’ codes which should help when Googling.

Thanks @Bobby_Nobble!
Tried using that term as well - nothing to be found for my Samsung Soundbar HW-J450 :frowning:

try going to

I just found out about discrete codes (never even knew such things existed) and was able to use their site to download codes for my TV.

just use the learn code service in HA to get the codes from your existing remote

Discrete codes are one that aren’t on the remote! Most common ones are separate power on and power off whereas the majority of remotes only have a toggle and others like direct selection of inputs.

thanks so much guys. I will try to check now. I hope I can mange

ah, ok. cheers!

Reviving the post… did you managed to get it working?
On config page, there is no rm3_pro…

Choose one from: rm, rm2, rm_mini, rm_pro_phicomm, rm2_home_plus, rm2_home_plus_gdt, rm2_pro_plus, rm2_pro_plus2, rm2_pro_plus_bl, rm_mini_shate, sp1, sp2, honeywell_sp2, sp3, spmini2, spminiplus or mp1. SC1 devices can be registered as sp2.