Broadlink RM Mini 3 does not work

I bought from

The firmware on this is 44057
Model: RM mini 3

On intelligent home center app from broadlink, the devices work as intended.It has no firmware upgrades available for it.On e-control app, it shows as unrecognized device, but shows.

On HA:

  - platform: broadlink
    mac: "xx::xx:xx:xx:xx"

and script:

      - service: remote.learn_command
          entity_id: remote.broadlink
          device: tv
          command: mute

When I called this service

entity_id: remote.broadlink
device: television
command: Turn on
alternative: true
timeout: 30

I got that error message:

Logger: homeassistant.components.remote
Source: helpers/
Integration: remote documentation, issues)
First occurred: 11:27:57 (4 occurrences)
Last logged: 11:32:30

Logger: homeassistant.helpers.service
Source: helpers/
First occurred: 11:29:14 (31 occurrences)
Last logged: 11:32:49

  • Unable to find referenced entities remote.broadlink

Using broadlink manager gives the following:

Then I tried python-broadlink and BlackBeanControl

I changed the line 167, I wrote RealTimeout.

Then I got that:

What is the problem? Someone can help me?

Thank you in advance

From Banggood LINK

Then I got that:

I tried as switch. I call a service (host:
I got this:

Logger: homeassistant.components.broadlink
Source: components/broadlink/
Integration: broadlink (documentation, issues)
First occurred: 19:19:28 (1 occurrences)
Last logged: 19:19:28

No signal was received

I too am struggling with my RM Mini3. I set it up perfectly about a year ago and it’s been working without issue. In the past few weeks the commands haven’t been going through on it, so I just checked and found this:

I am checking my node-red logs, and am receiving the following error:
“Broadlink Timeout Received - Closing Device Connection”

I believe this is all part of the same issue.

Just found this post, Brodlink updated his firmware and broked the HA compatibility

Thanks, I checked.
I tried this method (with node-red), but during learning proccessing I get ““Broadlink Timeout Received - Closing Device Connection””.

I was dealing with the same issue. I’ve one older broadlink rm mini3 and one added 2 weeks ago. The newer one wouldn’t work.

Since Home Assistant 0.110.2 the broadlink library and integration got updated! When you have a newer broadlink rm mini3 use type: rm_mini3_redbean in your config.

If you’re still having issues, check:

1 Like