Broadlink RM PRO errors

I recently purchased a Broadlink RM PRO to controll my RF sockets which works great!

Setup as follow:

  - platform: broadlink
    host: xx.xx.xx.xx
    mac: 'xx:xx:xx:xx:xx:xx'
        friendly_name: Table Lamps
        friendly_name: Couch Lamp
        friendly_name: TV Lamp
        command_on: 'sgC4AR4MCgQODgoHEAkfCx8KHwsLHwsgCgQEGR8LC50fDB4MHgwKIAoEBRYfDB4MCh8LHwsZESAfBCYMChAEDSAKCx8fCx8LHwwKBAoSCSEfCx8LHgwKIAkgCiAfCwqeHwweDB4MCh8LIB4LHwsKIAsfCiALHx8LHwsLHx8LCx8fCx8LHwsKIAsfHwsfCx8LCiAKIAogHwsKnh8LHwsfCwogCiAfCx8LCiALHwogCiAfCx8LCiAfCwogHwsfCx8LCiAKIB8LHwsfCwogCiAKIB8LCp4fCx8LHwsKIAogHwsfCwogCiAKIAogHwsfCwogHwsKIB8LHwsfCwogCiAfCx8LHwsKIAogCiAfCwqeHwsfCx8LCiAKIB8LHwsKIAogCiAKIB8LHwsKIB4MCiAfCx8LHwsKIAogHwseDB4MCiAKIAogHwsKnh4MHwsfCwogCiAfCx4MCiAKIAogCiAeDB4MCiAeDAogHgweDB4MCiAKIB4MHwsfCwogCiAKIB4LC54eDB4MHgwKIAogHgweDAogCh8LHwsfHwweDAogHgwKHx8MHgweCwsgCiAeCx8MHgwKIAogCSAfAAXc'
        friendly_name: LG TV
        friendly_name: Sfeerhaard

I can’t seem to turn off the TV (the strange thing is it does work about 1/50 of the time) allthough it’s the same button on the remote as the power ON button and it does work from the Android App).
I have tried using other code’s (with the learning feature) but unfortunately I get the same result.

Any errors in your log?

In my experience, the RM PRO is quite fussy about the code recording. Some things I found helped:

a) Wait for one second after the light comes on the box until pressing the remote
b) Hold the more REALLY close to the unit, 3-4 inches worked reliably for me
c) Only hold the remote button for something like a quarter of a second.

And if that doesn’t work, try it again until it does.

Also, I assume that there’s good line of sight to the TV from the RM PRO ?

Only these but I don’t think they are related:

Traceback (most recent call last):
  File "/srv/homeassistant/homeassistant_venv/lib/python3.4/site-packages/homeassistant/components/", line 67, in trigger_service
    pyfttt.send_event(key, event, value1, value2, value3)
  File "/home/homeassistant/.homeassistant/deps/pyfttt/", line 12, in send_event
    return, data=payload)
  File "/srv/homeassistant/homeassistant_venv/lib/python3.4/site-packages/requests/", line 110, in post
    return request('post', url, data=data, json=json, **kwargs)
  File "/srv/homeassistant/homeassistant_venv/lib/python3.4/site-packages/requests/", line 56, in request
    return session.request(method=method, url=url, **kwargs)
  File "/srv/homeassistant/homeassistant_venv/lib/python3.4/site-packages/requests/", line 488, in request
    resp = self.send(prep, **send_kwargs)
  File "/srv/homeassistant/homeassistant_venv/lib/python3.4/site-packages/requests/", line 609, in send
    r = adapter.send(request, **kwargs)
  File "/srv/homeassistant/homeassistant_venv/lib/python3.4/site-packages/requests/", line 497, in send
    raise SSLError(e, request=request)

I will try. But the strange this is that the TURN ON command is working as expected (without any exceptions). And yes, the line of sight is fine.

if the ON works well, and the OFF not (and is the same button), to me looks like more a problem with the TV

Can be, but the remote works flawless and I never had any issues.

I noticed that when I keep tapping the switch, eventually it will turn off so the learned code is recognized.

Do you have to hold the button down to get it to go off, in which case it’s expecting a few repeats before responding, your tapping may be achieving it. In my experience is usually turning on that needs the repeat but I haven’t had an LG to know how they do it.

Check if your TV has two different codes for on and off (some have, even if remote has only one button)

1 Like

Nope, that’s not the case, tried that as well.

I’m allmost certain it doesn’t, remember it works fine from the app so perhaps I have to export and convert the code’s stored in the app.

With my RM Pro that i just got today, i plugged it in and it was blinking fast, i got the app and i tried connecting the device, and it had an error saying to reset the device, so i did, and it still had the problem saying the wifi is too weak, and im not in the middle of nowhere im near the coast in california in an urban area. And my phone connects to both my 2.4 and my 5 ghz wifi seemlessly, I even attempted it in the part of the house with the strongest signal, and i even tried connecting to the devices wifi, but it doesnt even show up and i cant manually connect to an unfound wifi network by its name. I dont know if i have to change any settings to my wifi but every phone that has ever entered this house is able to fonnect to wifi by simply typing in the password. Can anybody help at all?

In my case I had trouble connecting to my 5ghz network so i’m using my 2,4 ghz network.


I just got my RM Pro and the first time around the configuration failed. I have been trying to reset the device but its not working. The Wi-fi LED continues blinking. I have also confirmed that the device is not in AP mode.
Any suggestions?

maybe is picking up a different wifi? The first configuration its tough, you have to try and retry

hey @anon35356645

Opened the device and the saw the reset button was not connected properly on the circuit board. Problem solved!

1 Like

I just got my Broadlink RM Pro and tried connecting the device. It failed and ask to reset it and still failed. I also tried other phone still the same result. I can anybody help me?

Either persevere and it will work eventually …or you have a duff one!