Broadlink rm-pro not read RF values


Recently i bought a broadlink rm-pro to use with the IR and RF, because i have a rf rollershutter.

I configured all IR controls in HA like TV, aire conditioned, vacuum, etc but when i want to read RF values always HA display that was not Rf signal readed.

Someone how a method to do it?


Hello @garvarma.

I am too not able to learn RF packages. I think this is something to fix on HA Broadlink component.

If I need RF codes, I learn using E-Controll app and get the codes using the method discribled on the component page (USING E-CONTROL REMOTES):

It works!

Cheers mate!

Just to put a kink in things. I was able to learn rf codes using HA no problem. I have a simple rf 4 button keychain transmitter which came with a device I was trying to automate. Hit the learn service for the rm-pro, held the device about 1 foot from the rm-pro and it picked it up perfectly, even the length that it was held for (matters for my application) was part of the learned code that I grabbed from the front end.

1 Like

Hello @azeroth12!

Yes! It might be a problem with my RM2 device.

I have to press abou 10 times the send service to learn package then the light turn on one the device. After pressing the button my 433 controller, for example, the light turns off and code “AAAAAAAAAAAA” shows up on fronted.

No idea why.

Odd, is the device on the latest firmware? You can update it using the mobile app if its not. Most of the firmware updates have had notes mentioning code learning improvements.

1 Like

Yes! I’ve updated the firmware but I think this was happening before that. I just hope BroadLink doesn’t close this door because of systems like Home Assistant.

Not really following this last statement. If the firmware fixed it i would expect it to be happening before.

Not sure what door you’re referring to. Not sure why broadlink would care if we incorporate their hardware with HA. We are still buying their hardware and they are making money.

Sorry, English is not my first language :slight_smile:

I was never able to learn any codes using my RM2 unit. Even after firmware update. Only IR codes. Maybe it’s a problem with the unit or with my Hass.IO installation.

About the “door” I was talking about is that BroadLink could update the firmware so we can no longer use other software like HA to control things. Some companies has those kinds os policies so the experience of the end user is consistent to their products.

I agree with you: I don’t think they will do that as long as units are being sold.


Ahh gotcha, yeah hopefully not. Too bad about the RF codes not working, I can’t really help as it worked fine for me. If I remember right, I think it worked better if I held the button a bit longer but not sure otherwise…

1 Like

I haven’t needed to learn any for ages but it used to be generally accepted that you needed to restart HA and do the learning immediately to get any reliability.

Hi @Schneider,

I will try this option, but I don’t have a android phone for now.

I will notice you


I’m having the same issue, I could learn IR codes but not RF codes with my RM Pro+.

I have the same problem with my RM 2 Pro. Can’t scan RF in HA, only IR. But in IHC and e-Control all works fine.

Hi, did you solve this issue, I’m having the same problem.