Broadlink RM4 Mini

It should be ok soon!

The broadlink library used by home assistant has been updated (0.12 => 0.13). And there was a push request that has been merged in home-assistant to use this new version. =>

So the RM4 mini should work with the next upgrade !



I moved to HA version 108.1 (contain the Broadlink 0.13), but I can’t use the RM4 mini.
Has anyone succeeded already ?


I tested on the latest version as well. Still no joy.

Broadlink RM4 pro does not receive a signal using the broadlink.learn command, when you start the broadlink.learn service on the device, even the indicator does not light up to press a button and get the code in the Home Assistant. I read the comments that supposedly will be fixed in the next update, well, there were already 2 system updates.

Could you help me?
My Broadlink RM4 mini does not to add to my router which has a password with 64 characters.
I do not want to decrease the characters number of password.
What can I do to connect Broadlink to router.
Thank you!

I’ve just managed to do it. I managed it by

import broadlink
broadlink.setup('MYROUTERSSID', 'MYPASSWORD', 3)
  • Put my RM4 into AP Mode (Hold reset until it flashed 4 times, stops and flashes again)
  • Connected my computer to the Broadlink over Wifi. Mine was called Broadlink_Wifi_Device
  • Ran the python script I just created
  • Checked my router to see if a new device had been listed

I hope this helps


I will try.
Thank you!

It should be good with 0.109 !

Hello guys, I’m starting now at HA and I’m not an IT guy and I’m having a hard time adding RM4 to HA.
Would anyone have a video explaining how to clone the codes of TV remote controls and air conditioners to add to HA through the integration of broadlink?
I would appreciate it very much. Thank you.

I’m having issues with adding the RM4, so my next step is to unlink it from the app and all that.
If I do that, can I add it to the app again and it all works as it did before i unlinked it?
Or does unlink mean you have to start over from scratch if it fails with HA also?

I have a windows pc and would like to run this script without learning how to code in python.
Is there a step by step video or guide for using the python-broadlink script ?
Thanks in advance.

There is a Windows app, but it was last updated in 2019 so I am not sure if it will work with your device. If you do try it and it works then let us know.

1 Like

@Hellis81 - as far as I am aware you can never use the Broadlink app with that device again, or it will again block the device from communicating locally on the LAN and thus talking to HA

It doesn’t work.
It throws an unhandled exception when i try to pair my device to my wifi network.
I’ll try to run it with visual studio in debug but I have little hope.


In that case I’d rather buy another to test on.
Too much to gamble with

Do you mean we shouldn’t ever open the app again? Because I’ve got another RM4 mini I would like to add, and I’m not sure how to go about it.

Use another device?
Delete the app and install again with a new account.

I think you can simply delete that RM from the app. It will still work with HA.

Sorry to take this back a bit, but I’ve now realised that the first RM4 mini I added doesn’t actually seem to show up as connected on my router’s network map, and instead shows as offline.

I added it to HA anyway (with switch platform) in order to verify, and it doesn’t receive any IR signals with broadlink.learn, which makes me think it’s actually disconnected from my LAN.

However, when I open the Broadlink app, I’m still prompted to add it to the app, which I always cancel.
I thought this meant I’d set it up right (closed the app immediately after WiFi was configured and before adding it to the app), but since it’s not showing up on my network, did I actually do something wrong?

I tried reinstalling the app and resetting the RM4 mini and configuring WiFi again, but it still shows up as connected for about a minute before going offline again.

Is this normal? Am I doing something wrong in the process? Or is my RM4 mini just faulty?

This is probably why I used python-broadlink to add mine. I think I had all sorts of problems doing it the App way.

Are you able to run Python scripts? Adding using python-broadlink is real easy once you have done the hard work getting the script to run.

If you can run Python scripts, the broadlink integration author also has a script that will confirm local comms and do a test learn.

See this post: Broadlink Integration - add support for RM4 Mini and have a read of that thread.