Broadlink RM4C (RM mini 4) with Home Assistant

Does broadlink.send works for you on 0.109 with RM4C mini ?

I have an RM4 Pro… and no… it doesn’t seem to work.
i tried both:

  • broadlink.learn
  • broadlink.send

and both with rm4c_pro and rm4_pro as Type (not sure about the difference).
No joy



I’m new to Home Assistant, my version is the stable one 0.109.2. I own a RM4C Mini, it has been reset to be only included in the local network and not in the cloud.
I setup the configuration.yaml file as below

# Configure a default setup of Home Assistant (frontend, api, etc)

# Uncomment this if you are using SSL/TLS, running in Docker container, etc.
# http:
#   base_url:

# Text to speech
  - platform: google_translate

  - platform: broadlink
    mac: '24:DF:A7:34:96:04'
    type: rm4c_mini

group: !include groups.yaml
automation: !include automations.yaml
script: !include scripts.yaml
scene: !include scenes.yaml

I can see in the services both broadlink.lean and broadlink.send

Now I’m not sure what is the good way to operate a learn and a send. Can you please help ?

Thanks a lot,

o.k. HA version 0.109.4 released already
Does broadlink.send works for anyone with RM4C mini ?
It’s should be supported on version 0.109 already.

Hi, I was wondering how you set up your RM4C Mini for local network only. I’ve had a heck of a time just getting it connected to my network through their app. If you have a moment to let me know how you made it to be local only I’d appreciate it. Thanks!

The point is to avoid any RM4C link to the cloud, to do so here is the procedure:

  • Remove the device from Broadlink App
  • Factory reset the device
  • Add the device to your local network using the app (means configure the Wifi)
  • Do not set up a cloud (not now, not ever) => means as soon as the wifi is configured close the app and don’t do anything else

Got it…thank you! Yeah, saw that in the documentation a bit after I sent the message to you. Thanks again!

1 Like

Have the same question. I can reach my Broadlink mini 3 via this way and also execute the commands for learning/sending. But I don’t get any code back which I can implement in my automations :slightly_frowning_face:

Solved it: I accidently configured my Broadlink in the yaml as “remote” and not as a ""switch. After configuring it as a “switch” everything worked like it’s described in the documentation :slightly_smiling_face:

Maybe for you @dragonslore: I learned all commands like it’s described in the documentation. It goes like this:
Developer Tools -> Services -> broadlink.learn -> host: (IP of your Broadlink) --> call service
After you called the service: Point your remote controller in the direction of the broadlink and press the button you want to implement. Then you get the code you need as a notification (just copy it from there). I did this with every buttons I wanted to implement and saved the codes in an excel table. In my last step I followed the instructions of this video: (with the exception of using node red instead of the Hassio automation tool) to create some switches etc. in my interface. Hope that helps :slight_smile:

The only thing I don’t know until now is how to implement a volume slider or a status update for my booleans (e.g. that after a restart, Hassio knows that my receiver is on).

1 Like

Thank you so much LC7894, I tried again this morning after upgrading my home assistant to last version available and it works now like a charm (learn + send). :slight_smile:

That’s how it should be! Nice! :smiley:

Just setup with 0.109 and RM4 Pro. All working good thanks for the setup advice. In order to get the RF signals working see here onwards:

i have a problem, my Broadlink app need internet to set up rm4c but it connect with cloud automaticaly. So i cant connect rm4c to my Home Assistant.
Can you show me how?

To all.
I have RM4C mini and i configure it as a “remote” and all “remote.learn_command” and “remote.send_command” work well.
Step by step how i did it (hope this would be helpfull):

  1. Download Broadlink app from Google Play Market (
  2. Launch it and registration new account
  3. In main screen with 2 buttons press “+ add device”. Then Next
  4. Enter local WiFi password
  5. Factory reset my RM4C Mini by press on/off button for 6 secs.
  6. In app press Search. After that app start connect RM4C mini to my wifi.
  7. When it connected App request to add device . DONT DO THIS! Just close App.
  8. In Hass configuration.yaml add section
- platform: broadlink
  name: rm4_mini
  type: rm4c_mini
  mac: '24:DF:A7:4F:78:D3'
  1. Restart Hass
  2. And now you can use Services to learn and send commands
    Learn example:
entity_id: remote.rm4_mini
device: ac
  - turn on
  - turn off

Send example:

entity_id: remote.rm4_mini
device: ac
delay_secs: 2
  - turn on
  - turn off

how do you configure the wifi without the broadlink app, the ihc app does not know the rm4c

You can use the python app which is how I did it, but I have read that if you exit the broadlink app immediately after adding it to your network you can access it.

1 Like

I have learn from AC and I can send command (turn on and turn off), But How can I create a button to command the AC?

Where do you want that button?
Did you learn as a remote or switch?

I learn as remote.
But what I want to do is an Air conditioner control, like a thermostat (in the lovelace)

I don’t believe that is possible.
Does your current IR remote have a display?

Yes my remote have a display.
I’m trying with smartir, and set the RM4 as switch.
The only problem is due to climate config, when I add “platform: smartir”, the configuration.yaml tell me there is problem.
I think the problem is due to I have another platform in climate config.