Broke it after two days. New user needs some help

Hello. Day two of playing with my new Pi and I have broke it.

I was working through this guide:

And had successfully installed Hassio, configurator, samba and was installing and setting up DuckDNS when I have clearly run into trouble and I am too new to know what I have done.

I am getting all these errors:

Setup failed for ssl_key: Component not found.
10:07 PM (ERROR)
Unable to find component ssl_key
10:07 PM (ERROR)
Setup failed for api_password: Component not found.
10:07 PM (ERROR)
Unable to find component api_password
10:07 PM (ERROR)
Setup failed for base_url: Component not found.
10:07 PM (ERROR)
Unable to find component base_url
10:07 PM (ERROR)
Setup failed for ssl_certificate: Component not found.
10:07 PM (ERROR)
Unable to find component ssl_certificate
10:07 PM (ERROR)

Duckdns Configuration looks like this:


“lets_encrypt”: {
“accept_terms”: true,
“certfile”: “fullchain.pem”,
“keyfile”: “privkey.pem”
“token”: “MYTOKEN”,
“domains”: [
“seconds”: 300

And my config file looks like this:


api_password: “MYPASSWORD”
ssl_certificate: /ssl/fullchain.pem
ssl_key: /ssl/privkey.pem

adding the api password was a setup stage for Configurator but I have never seen a screen that’s asked me for it, so not sure if this has caused the issue.

I have setup port forwarding as far as I can tell.
My other thought is today is the first time using the Pi without the flash drive in which had the config for the wifi? but the pi is connected over ethernet, and I can load http://hassio.local:8123/ and access the configurator etc.

Sorry, I am sure this is something really simple but need some help

Check the spacing of your config file under http:

http: should have not indention. The rest shoud be indented by two spaces.

Example: (edit: follow the link to see the indention, it isn’t showing properly in the preview)

Oh my god, so sorry that seems so stupid.

I have just amended that and it is letting me restart which it wasn’t before hand! I didn’t know the indentation mattered :s

Should I just have known that, or is there anything that tells me somewhere that’s what the problem is? Like a dubugger?

Thank you

Hmm, 4 minutes and I still cannot connect to it now using http://hassio.local:8123 :s

Read this:

the homeassistant.log file contains errors

Before restarting and after any config change run the ‘check config’ tool to check for errors.

YOu need to connect using https:// now that you have duckdns and lets_encrypt setup.

Dont use hassio.local. Its buggy.

You need to connect using after setting up duckdns and letsencrypt.

Jeez. Starting to realise how little I know now!

going through DuckDNS times out which makes me wonder if my port forwarding or config or who knows what is not right.

I can still access hassio from the network folder on my mac and view the config file or the log. log is showing:

2019-01-23 22:30:08 ERROR (MainThread) [homeassistant.core] Error doing job: SSL error errno:1 reason: HTTP_REQUEST
Traceback (most recent call last):
File “uvloop/sslproto.pyx”, line 504, in uvloop.loop.SSLProtocol.data_received
File “uvloop/sslproto.pyx”, line 204, in uvloop.loop._SSLPipe.feed_ssldata
File “uvloop/sslproto.pyx”, line 171, in uvloop.loop._SSLPipe.feed_ssldata
File “/usr/local/lib/python3.6/”, line 689, in do_handshake
ssl.SSLError: [SSL: HTTP_REQUEST] http request (_ssl.c:841)

Have i basically broken it?

Try https://yourexternalip:8123

You will likely get a security warning. This will test if duckdns is the issue.

If that doesn’t work try with your servers internal ip. Again you will get a security warning.

I believe the log entries are just telling you that you made a http request when HA now wants a https request.

Did you open a port on your router?

Thanks again

Is that my external ip for my pi or my mac that I’m using?

I set up (i tried to) port forwarding on my bt home hub5 to forward 443 to 8123 but on the router you apply the rule to a device so again I applied it to the ip of the pi, maybe that should have been the Mac?

No. It applies to the device hosting the service. The pi.

Then you can’t use a port number when you try to connect. Https by default is 443. No port number needed if that’s how you forwarded the port.

OK, so I have logged in via https://hassio.local:8123

I actually didn’t add the 8123 but after logging in (using legacy api password as for some reason it wouldn’t recognise password on the normal login screen it let me in and shows the screen). Now to sort out Duckdns

Right, so looks like I am back up and working!

I had no idents thanks for that @silvrr
I was trying to use http to access hassio not https thanks again
My port forwarding rule on my router somehow had the device name hassiohassio not hassio meaning the rule wasn’t applying to my pi.

With that fixed I am now able to log back in and log into Duckdns.