Broken Frontend after restart


So I restarted Homeassistant from the UI to see if that triggered discovery of some new mqtt components I have hooked up. No changes to the configuration, but the Frontend does not come back online.

The OS seems to work, and the addons also seems to be running since I can connect to the ssh cli and samba share. I can also restore snapshots and run OS updates, but any “hassio Homeassistant…” commands returns an “unexpected server response” error that tells me to check the logs. The logs are empty…

So far I have upgraded the OS, downgraded Homeassistant, restored several snapshots that was working before…

Any ideas? I was suspecting the rpi3 I’m running on, or the sd card, but since the os is running I guess it isn’t that? From the database which I have running on a NAS it looks like the recorder stopped logging events and states a couple of hours prior to my fatal restart…

can you try homeassistant as the hostname? It somehow was changed from hassio to homeassistant. Screwed me up bigtime yesterday after upgrading the system.

Not sure if I understand what you mean, I always access the Frontend via the ip address locally, and via a duckdns domain from remote. None of them works now, but on the remote connection I get a “508 bad gateway” from nginx. This indicates to me that the nginx add on is running, but Homeassistant is not…

Also, even if the hostname was changed, I should still be able to execute “hassio homeassistant restart” without errors in the cli, right?

Seems to be a different problem then.

Hi, I think I have a similar issue. Only on a Rpi 4. Now, after several reboots it runs again, but as soon as I try to update to 105.5 the frontend is dead.

The CLI commands have changed:

ha core logs should present you with the logs.
I am about to switch to a new SD card as no one has replied to my post :cry:

I had the same issues. Reinstalled everything and restored a backup. Also RPi4.

Hm, on which terminal interface are these commands valid?
I’m using the SSH addon for hassio, and login to that with the root user. I thought this was the hassio CLI?
The commands from your link is not valid there, looks like only “hassio…” commands are available.

Yep, I am using the SSH addon as well.
Are you using the latest HASSIO/supervisor versions?

yup, running the latest.
I re-flashed the sd card and restored my latest snapshot, so it’s up and running again now.

Still not able to use the “ha” commands though…

This was yet another reminder to me on how fragile this platform still is. I had made no changes to the config, I just restarted the server. I could reach the os, even update homeassistant, but there was apparantly nothing I could do to get it up and running again without the hardest of resets… After I migrated to hassio I also find myself using the “…host reboot” command more often, after homeassistant refuses to go back online after a restart.