Bruh Led strip won't turn on

I’m trying to get the Led strip working as per Bruh’s video, but whatever I do, I can’t get the light strip to actually turn on…
I’ve followed all the instructions and did the following troubleshooting:

  • I measured 12 volts going in, but also measured 12 volts on the other end, so the connection to the power seems solid
  • I only used a small strip (4 chips/12 leds) to test, so it can’t be voltage loss over that small distance
  • I tried it with various test strips, from two different led-wheels (to make sure that the one was using wasn’t faulty)
  • the NodeMCU is working, I see it in HA, including the selection options (if it is not working the selection options don’t show)

I have a suspicion it is related to the logic level converter. I measure 5v going in, but 0 on the other side (which should be 3.3v i think). I have tried that with three different level converters, even from different brands - same effect.
So based on that I would think that the signal doesn’t get changed from 3.3v to 5v which could be the cause.
I tried connecting the signal directly (so 3.3v going into the strip) but that didn’t work either. But I would think that once you put power on the strip it should light up, and then with the signal you can change the colour or effect?

Any suggestions? I’m lost…

what model number are the LEDs or LED strip? Is it exactly the same strip he uses? I think you need a 12V data signal for those. If the LEDs are the 5V variant, 3.3V will work on the data line. I can confirm that because I created my own LED strip with a NodeMCU and a strip of ws2812b.

also have you tried without the logic shiftier? I have 1 working with it fine, but decided not to use one on another I made, also working fine. Not sure if it is really needed? Don’t quote me on that :wink:

I think they are the same.
They are 12v
I tried without the logic shifter and that didn’t work either.

You could be right about the data needing to be 12v too, but then the question is how do I make it 12v? The signal is 3.3v out of the nodemcu, logic shifter makes it 5v - how do you get the 12v? Or should I give up on the nodemcu option and use a different controller?

In the videos I watched on YouTube they seem to light up though as soon as they get power, and mine are not doing that.

It’s these:

I have a 12v strip with no logic level shifter. Works fine. Have you checked the arduino sketch to make sure that it is working? Open the serial monitor with the nodemcu plugged into computer and when clicking on the HA buttons, you should see info coming thru on the serial monitor.

Yes, I did that in serial monitor - nodemcu logs on to network fine etc.

So if I understand you correctly, I could do the following:

  • connect strip straight to power adapter
  • connect pin 5 from nodemcu straight to data on the strip
  • Power nodemcu with usb cable
  • don’t bother with logic shifter and 12v-to-5v stepdown

I’ll give that a try tonight - thanks!

If you are powering nodemcu via usb have you also grounded the nodemcu to the power supply of the strip? They need to share common ground.

That’s it!

I tried it with the following:

  • Led strip connected directly to power supply (at 12v)
  • NodeMCU powered through USB, so at 5v
  • Pin 5 connected directly to the data connection on the strip, so at 3.3v, I left the logic level shifter out
  • Connected the GND on the NodeMCU to the same ground on the power supply
  • Turned on power

The lights didn’t turn on right away, but once I used the switch in HA I was able to turn them on and control all the various effects.

Now to move on from the small test strip to the full 5m and connect them to the veranda, but that should be easy now that I have this step working :slight_smile:

Thanks for your help!

ah so you didn’t use a DC Converter 12V Step Down to 5V? as this would mean you wouldn’t need the extra plug via the USB, so just 1 plug needed

I didn’t, as my main goal now was to make it work in the most simple way.
But I will probably put the step-down back in for exactly the reason you’re saying here, before I do a permanent installation.

I struggled here as well. Wish there was some mention on the Bruh video. A usb power source is pretty common for the nodemcu even if only temporary.

Anyways glad you got it working.