Bryant Evolution Thermostat

Hi, very new to Home Assistant and wondering whether there is a way to integrate the Bryant Evolution thermostat with Home Assistant? Thanks!

You may want to follow this thread. Carrier Infinity integration as works similar to Bryant.

thank you for your response… this is way over my head. I guess I have to wait until Bryant provides an open API. Thanks!

I’m not have the great success that the rest of the people are having. The first thing I tried to do was see if I could see the packets streaming. To do this, I got an OrangePi with a 32GB microSD card and an USB to RS485. I loaded the OPi ubuntu sever OS. Since 24VAC is there I got a 24VAC to 5VDC power supply. I used the program screen observe the traffic on the RS485 bus.

Before I went up in the attic, I did a test and ran data between my PC (using putty) and the OPi. My BAUD rate was 9600 To emulate the 24VAC I used a 120 to 12VAC 40VA transformer This all worked as expected.

When I connected to my heater (Bryant Model No. FE4ANF005L00EEAA): A to A, B to B, C and D to AC-IN a lot of magic smoke was released. The heater wasn’t damaged, and I was able to revive the microSD card. Power supply, OPi and RS484 adapter were all rendered not functional.

This time I took out my oscilloscope to check the wave form from A to B. To ensure that I didn’t have grounding conflict, I plugged the O’scope into an isolation transformer. I put the 'scope ground on B and the probe on A. Yup! Some serious differences

Waveform USB-RS485
Waveform of the USB-RS485 (19200 BAUD)
Waveform heater
Waveform of the heater

You’ll note the USB-RS485 is ~ -0.2V to ~ +2.5V and the heater is ~ -3.5 to ~ +3.5

I notice that the power supply is not isolated, The AC goes into a full wave rectifier, and the negative side of the rectifier is DC V- That’s what probably did me in. I now have an isolated 120AC to 5VDC 700mA power supply (OPi needs about 300mA).

But I’d still like to know if it’s OK to connect the USB-RS485 up to the A and B?

Anybody out there have any thoughts?

I went ahead and tried the connection using an isolated power supply. I guess that part could be called a success because nothing lost its smoke. But the serial information is coming out as gibberish. I’ve tried a number of different BAUD rates to no avail.

From the oscilloscope, the BAUD rate is about 23400. which makes me think that the BAUD could be non-standard and/or the data is binary.

Anybody with any thoughts?