BT-tracker: how to install "pybluez” installed on my rpi?


I am trying to configure blutooth tracking and have a question about that.

I have configured config.yaml according to

HA boots up without a problem but I don’t see any BT devices in known_devices.yaml.

Probably because pybluez is not installed on my rpi.
If I ssh to the rpi I cannot install the package.

Annotation 2020-03-26 163240 .

I found this clue on the Inernet “In hassio there is no such thing as apt-get. you can’t do this! If you want this, you have to use raspbian or a virtual environment. Hassio is a device. ’

How do I get “pybluez” installed on my rpi?

Thanks in advance.

Regards, Ko

It is installed, it’s part of the manifest. If you configure it, it gets installed. You’re also not running on debian.

Thank you for your response.

To test it again I removed known_devices.yaml and restarted HA with some iphones nearby with both Wifi and BT turned on.

Still no BT devices in new known_devices.yaml.


I guess these are al Wifi entries. I understand that BT devices start with prefix “BT” - is that correct?

My config is already following:

Am I doing something wrong? Is additional configuration required?

known_devices is no longer used… It was phased out in 0.94.

I.E. Look in your states page for the entities or the devices page.

I see a few BT-entities in the states and devices page, among others our TV.

I see them by the way also in the new created known_devices.yaml :wink:

But still no iphones.

I guess I still miss something …

I wouldn’t expect that to stay, see note in yellow:

Are those bloothooth devices created by this integration? If so, then it’ll be on your phone’s end.

Yep, the BT-devices are created by this integration.

In the HA-log I see rhe following entry (multiple times)

2020-03-26 19:37:36 ERROR (MainThread) [homeassistant.components.device_tracker] The see service is not supported for this entity device_tracker.kophone
2020-03-26 19:38:01 ERROR (MainThread) [homeassistant.components.device_tracker] The see service is not supported for this entity device_tracker.kophone

kophone relates to my iPhone on which I have the IOS-app running.

Does that ring a bell?

In our house are four other iphones and and one Galaxy-S9 “active” with BT turned on. No shred of them in HA at the states or devices page.

Also did some tests with a modified config

  • platform: bluetooth_tracker
    track_new_devices: true

But the same behavior …

Unsatisfactory and annoying!

Someone with the golden tip or trick …?

Did you try the suggestion at the end of the bluetooth tracker docs:

In some cases it can be that your device is not discovered. In that case let your phone scan for Bluetooth devices while you restart Home Assistant. Just hit Scan on your phone all the time until Home Assistant is fully restarted and the device should appear in known_devices.yaml .

Yes, I had tried it … and I thought without success.

But I hadn’t done it right: turning BT on / off was not the way to do it (an iPhone doesn’t have a scan button ;-)).

But when I later connected the iPhone via BT to another BT device, it was picked up by HA.

So solved.

Thank you for your help.

LIke your icon, been there many times

spartan races? Or what Icon you talking about?