Bug: Generic camera stopped - Basic Authentication not accepted in URL anymore?


Since a recent update (0.31 or 0.32, I can’t remember) my generic camera with the username and password in the URL has not been displaying.

My URL had included a username and password using Basic Authentication in the URL.

Here’s a snippet from my config file

camera nameOfCamera:

Is this a bug in a recent build? It was working until recently.


Pretty much all my cameras are using the generic driver - even my Foscams as the Foscam driver doesn’t work for me. They all use basic authentication as well and all are still working as of the latest update (.32.3) for me.

Same thing has happened to me. I’m using the ffmpeg camera to get it to work, but it doesn’t show realtime updates when I click on it, so I’d rather go back to generic. Any luck?

Same issue with my generic ip camera. I was able to fix this by adding this to the configuration.
authentication: digest


Perfect - that did the trick! Adding authentication: digest fixed it. Thanks for contact me :slight_smile:

1 Like

damn, 4 years later, 2020, still have the same issue, and adding authentication: digest fixed it