Bug in sensor state display?

When clicking on UI a sensor binary sensor display, history window opens (as it should):


Notice the bar on top vs. states informed lower? The changes in sensor state are not displayed. When clicking the pop-up header, it opens in a bigger pop-up, and sensor states are not visible there either. The changed states are long enough that they should be visible.

When clicking the upper “Show more”, the dispaly is OK

This behaviour is with all the browsers I have installed.

A bug probably?


This is a history_stat type of sensor.

This morning I noticed another thing with the sensors based on this same physical binary sensor… My binary sensor monitors my oil burner on / off states. The following, for example, is the monthly run time. I have similar sensors set for weekly and daily runtime, and they act the same way.


I reset mys system twice in the mornings at 5:10 and 5:16. This is what has happened. The configuration of the sensor is as follows:

  - platform: history_stats
    name: Burner ON this month
    entity_id: binary_sensor.boiler_room_burner_monitor_1
    state: "off"
    type: time
    start: '{{ now().replace(day=1).replace(hour=0).replace(minute=0).replace(second=0) }}'
    end: "{{ now() }}"

Something strange going on with history_stats…

In both cases, restarting the system sorted the problem. See below:


This behavious occurred after the latest core update 2022.6.2 and seems to activate randomly

EDIT again 8.6.2022

This time I’m getting this kind of readings from history_stats of binary sensors, an eaxample.


Whatever the case, they d4efinately should not look like this, e.g. showing 2 separate line of values at the same time.

These values are based on configuration.yaml structure (like the others with same error):

  - platform: history_stats
    name: Bathroom_AC ON this week
    entity_id: switch.kylpyhuone_ac_teho
    state: "on"
    type: time
    start: "{{ as_timestamp( now().replace(hour=0, minute=0, second=0) ) - now().weekday() * 86400 }}"
    end: "{{ now() }}"

…and these have worked OK for ages, but suddenly they do not anymore after latest updates??? See also how it resets itself after a restart in the morning and starts calculating from 0, and it should not.

An earlier insident from the same timeline shows this:


Now, based on the .yaml, there should be nothing causing this jump to value 6 at approx. 0:46. It is reseted back to normal in the morning, when there is a restart.

Now, after one more restart, the graphs show real values again:


What’s going on?