Button-card disappeared!

Hi,
After I update he HACS frontend all custom: button-cards has disappeared!! I tried to update HA and restart it and clear the cash but all this not helped, I tried to replace “type: custom: button-card” with “type: button” and the buttons appears, any idea?


Try to reinstall custom:button-card.

I tried that and it didn’t work

Can you post example code ?

Sure

show_name: false
show_icon: true
type: custom:button-card
styles:
card:
- padding: 5%
- background-color: rgb(215,213,220
- border-radius: 15%
- height: 90px
- width: 90px
name:
- color: white
- font-size: 18px
- justify-self: right
icon:
- color: rgb(77, 124, 42
- height: 55px
- width: 55px
- padding: 0px 0px 0px 0px
- font-family: sans-serif
action: navigate
tap_action:
action: navigate
navigation_path: weather_maps
name: ألطقس
icon: mdi:map-outline

There are several misspellings in your code.

The closing brackets are missing:


background-color: rgb(215,213,220

color: rgb(77, 124, 42

action is duplicated:


action: navigate
tap_action:
  action: navigate

It’s the same codes before the updating, I restored the backup and up date operation system and home assistant core but I keept HACS frontend, now the buttons appeared, I will fix the codes and update HACS frontend again