Buttons Missing after 2023.4.1

Since upgrading to 2023.4.1 I have buttons missing all over my dashboards, but the entity itself is still on HA and reports the proper value. I’ve tried on 5 different browsers and cleared cache so I don’t think it’s a caching issue.

For example, on my Weatherflow device you can see the buttons missing:

One of those is the relative humidity, which is present and has a value:

It’s not tied to just one integration, I have this across the board whether it’s template entities or non template entities. While I do use some mods in places, the screenshot above is 100% pure HA.

Any ideas what might be happening?


Seeing the same issue - on my pop out menus, the buttons in GRID card are gone. The code is still correct, so I’m not sure what the issue is

Might be this issue: Button card disappeared · Issue #16114 · home-assistant/frontend · GitHub

@pedolsky thanks for the link, that does indeed seem to be the same issue with anything showing % as a value

2023.4.3 still no buttons in dashboard, no units shown as % just regular buttons for lights switch


Interestingly my standard buttons only disappeared after 2023.4.3.

                  - type: button
                      action: toggle
                    entity: switch.light101
                    name: Bed Lamp
                    icon: mdi:desk-lamp

Running into the same issue. This is my button:

- type: button
  show_name: true
  show_icon: true
  name: Reset
  icon: mdi:delete-empty-outline
  entity: button.litter_robot_reset_waste_drawer
    action: toggle
      text: Are you sure you want to reset the Litter Robot Waste Level?

Following thread.

The issue on Git is still open. That’s pretty surprising since this is a fairly major break.


The same on 2023.4.3, also changed Android widget buttons and need’s to be recofigured. And some spaces loosed for several objects. Quit strange update.

Same error.
It is interesting that buttons are not visible on the desktop computer (Chrome browser) and in the Android app, while they are normally visible on the Chrome browser on the Android phone.

Following thread.

I can’t see them on my android phone using chrome. So now they are completely gone :frowning:

Same issue here.

Buttons had been working since i updated to 2023.4.3 this morning.

After a backup restore they came back.

Had the same problem with custom button card, only appeared this morning with 2023.4.3, not related to buttons showing percentages (as was mentioned in a related issue).

Workaround is here:

EDIT: this fix is already merged into the code in version 2023.4.4 so you should get the fix by simply upgrading.

This is definitely a bug, but there is a workdround by setting one of your locale settings to something other than auto:


refer to : Button card not showing in 2023.4.3 · Issue #16155 · home-assistant/frontend · GitHub


I can confirm that the work-around with going into your profile and changing one of the settings away from auto is a functional work-around for 2024.4.2. I’m not adding as a solution only because it is a work-around rather than a fix.

Resetting one of locale fix it for me as well. I was using buttons to play various media streams.

2023.4.4 was just tagged with the fix for this

according to bram kragten

I had the same problem as above and update to 2023.4.4 solved the problem.


Broken for me after update today
Home Assistant 2023.4.4
Supervisor 2023.04.0
Operating System 9.5
Frontend 20230411.0 - latest

I’ve got the same issue, it has persisted sisnce i updated to 2023.4.1.

I upgraded to 2023.4.4 this morning and I still have the same problem. All my buttons are gone and when trying to create a new one, this is what it looks like:

1 Like