Calibrating Fibaro roller shutter 3 with Somfy LT50 jet motor

Today, I had a sunscreen installed with a Somfy LT50 jet motor.
It came with a simple wired switch, but since I had a Fibaro roller shutter 3 (FGR223) lying around, I figured that I could use it to control the screen.

I wired it like this, and included the roller shutter.

I am able to control the screen, moving it up and down works like a charm. I am however unable to execute calibration, so home assistant doesn’t know the position of the screen.

I tried calibrating it in 2 different ways:

  • Move the screen down
  • press the b-button on the module, release it when the led is white
  • quickly press it again

The calibration seems to start, the screen moves all the way up, but then it stops (it should go down and up one more time)

I tried the same by changing parameter 150 to “force device calibration”, but exactly the same happened.


Any idea what could be going wrong?

This is the device info:

and these are some of the device settings:


I’m using home assistant 2022.4.7 with zwaveJS Driverversion: 9.0.7/Serverversion: 1.16.1 and a Aeotec Z-Wave Plus Z-Stick gen5