Calibre-web hassio addon

@bestlibre

Which are the settings? I installed it, but not sure what else to do

1 Like

I have installed yesterday and find out still not enough info, so it may help other people:

  • install Calibre server on PC from here: https://calibre-ebook.com/download
  • set Calibre server by adding ebooks
  • copy the Calibre folder from the PC, include everything inside:
    • ebook folders (usually by author)
    • metadata.db and metadata_db_prefs_backup.json files
  • create a folder on the hassio, I did it inside the configuration folder
    • paste all the info in this folder (ebooks and the mentioned two files)
    • restart addon
  • access the server hassio:8083 or whatever port you set and write there the Calibre directory, for example configuration/Calibre
    After this you will have the calibre library available on the hassio server.
    However I find this server less nice comparing to the full Calibre server regarding the available interface inside the ebook reader app.

I am trying to figure out. Is there a calibre-web addon? I cannot find it.

For anyone interested, Calibre is a powerful and easy to use e-book manager . Users say it’s outstanding and a must-have . It’ll allow you to do nearly everything and it takes things a step beyond normal e-book software. It’s also completely free and open source and great for both casual users and computer experts.

More info here

Yes, it is, but you have to add a new add-on store from the Supervisor menu in order to get it: https://github.com/bestlibre/hassio-addons

I’ve played with this add-on a few times and never seemed to get it set up. I can install it and it starts, but no connection on port 8083. Did you make any edits to the ‘Config’ and 'Network ’ sections of the add-on in Hassio to get yours to work?

After addon installation, you must set the Network host port - it could be 8083 - then start or restart the server.
Afterward the web interface is available at the address hassio:8083 (or whatever port you have set). Here you will do some settings, like allow anonymous access to the library.

Thanks, that seems to have worked.

Hi guys! I just realized Mihai answered and a new discussion started. I tried following your advice but I am stuck. I installed the addon, I changed the host port to 8083 like you both suggested and restarted. I even restarted Home Assistant just to be sure. I still cannot access the Calibre interface. I am guessing it is running at the same IP as Home Assistant, right?

Any help would be truly appreciated!!

:open_mouth: I got it to work!

May I ask how the path should look like for the folder sitting inside of HA config folder?
I am not that good with Linux (actually total newbie) :smiley:

It may looks like:
configuration/calibre

When I was setting mine up I found a slight directory syntax issue. When the Calibre Web addon (on the page http://“your hassio address”:8083 if you use port 8083) asks for the location of the Calibre library folder I entered the path as share/calibre (ie no leading slash using the share directory and a folder named calibre holding the books). This did connect and gave me the listings, but no cover images or download capability. When I entered /share/calibre (with a leading slash) it all worked fine.

This add-on is really the missing piece for my Hassio setup. I have 20 GB of books on a 64GB SD card in an Rpi 2. Within the admin section of the add-on you can update to the latest version of Calibre Web, although it will revert if you restart the Rpi. Calibre on my PC won’t use the share directory as the main library as it sees the share directory as corrupt. As a workaround I have mounted the share directory on my PC and use Rsync to mirror the two libraries so that when I add or read a book on one side it eventually matches up on the other side.

Thank you, guys for all your help. I will try to follow your advice and let you know. In the meantime, here is a guy that is making a series on OpenMediaVault and this is just out. Running full calibre on OMV: https://www.youtube.com/watch?v=oHC6J_aN4eQ

Maybe you are interested. I am actually running OMV as a separate container beside HA on a Proxmox machine. So I will definitely try both versions.

I tried both solutions but none work for me :confused:
For now I will stick withe the OMV full version of calibre.
Thank you for your help!

I use Calibre Web all the time running in Homeassistant on my Pi 2. Recently the add on has been stuck in a boot loop on the latest HA version on my machine and I was not able to debug it. I had been mean meaning to investigate Portainer and now have a Calibre Web container working under it (pending some time to see if it’s stable). Here is what I did if anyone is trying the same:

-Backup with a snaphot in HA and download it just in case.
-Install the Portainer add-on. As the documentation says: Disable Protection Mode and restart it.
-Identify your PUID and GUID numbers. I did this by going to the SSH add-on Web GUI and entering “id $user”. Mine were both 0, but this may not be every case.

  • Go to the Portainer Web GUI and select ‘Stacks’ from the menu bar, then ‘Add Stack’
  • ‘Use the Web editor should be selected’. Give the stack a name, then paste in the following into the Web editor window:

version: “2.1”
services:
calibre-web:
image: https://github.com/linuxserver/docker-calibre-web
container_name: calibre-web
environment:
- PUID=0
- PGID=0
- TZ=America/Los_Angeles
- DOCKER_MODS=linuxserver/calibre-web:calibre
volumes:
- /mnt/data/supervisor/share/Calibrewebconfig:/config
- /mnt/data/supervisor/share/Calibrelibrary:/books
ports:
- 8083:8083
restart: unless-stopped

-Change your PUID,GUID,and TZ (you can google the TZ list for your time zone) as necessary.

  • Change your :/config and :/books (ie where your Calibre Library of books is on HA) directory to your. My example shows folders that will be in the ‘Share’ directory of HA. NOTE: I found Calibre Web did not like directory names with a space even with quotes or an escape character, so I changed ‘Calibre Library’ to Calibrelibrary.

  • Press ‘Deploy the stack’ at the bottom of the page

  • The stack should deploy, after several minutes the Calibre Web should be up at https://:8083. It takes some time to intially install and boot the web server.

  • The landing page should be ‘Basic configuration’. Enter and save /books to point to your library. The defaults are U: admin P: admin123