Calling “input_select.select_option” service in Node Red Fails

NodeRed throws an API error when I try to use call a service from the “input_select” domain. Is this a missing feature or am I doing something wrong?

  • the error: “Call-service API error. Error Message: Service not found.”
  • my configuration: Call Service Node
    – Domain: input_select
    – Service: input_select.select_option
    – Entity Id: input_select.primary_target_temp
    – Data: {“option”: “Living Room”}
  • additional info: The input_select entity is configured and works perfectly on my frontend and in the ‘services’ developer tools. In NodeRed, when I start typing ‘input’ in the Domain field, the only autocomplete options are “input_boolean” and “input_datetime”.

Background: I have multiple hue motion sensors around my house. I want to use their built-in thermometers to inform the thermostat to adjust the temperature for the room with the most recent motion event. I want to be able to adjust the primary target room from the frontend and from NodeRed.

This post is related to one over in the NR forum here:

Any help is greatly appreciated!

Have you tried restarting node red since adding the input select in HA?

Isn’t the service just select_option and not input_select.select_option

1 Like

Thanks! That solved it.