Camera Integration Axis 2130, 2100 and Xiongmai

I have a couple of old Axis cameras:
A 2130 and a 2100, that I would like to get integrated, I know it’s old, but it’s a great little ptz camera, any idea if I can set it up; when i try it says bad credentials.
I also have a Xiongmai camera that has all access blocked to and from the outside world, is it possible to integrate this?


Those axis cameras are way too old to use with the Axis integration

Is there any other way of integrating then, or could you recommend a camera that I can integrate? As low cost as possible, ideally poe if possible. How about the Xiongmai?

I only use axis cameras so can’t really be of help outside of that context

Figured both out:

I can integrate them using the generic camera platform.

Thanks for your help.

Is it possible to share what you figured out? I have an Axis 213 PTZ and struggle all day to integrade this in Hass. Tried everything I read about. Ofcourse in a browser no problems.
Someone else who got this type working? Please respond. Just a configuration to use it as a still and/or streaming cam is alright. Don’t need the fancy parts :wink:



Hi @fbockstael Welcome to the HA community. How are you finding it?
Here is a snip from my camera configuration, I hope it’ll help.

I setup another user called HA on the camera with just viewing permissions. I hope that helps.

- platform: generic
  name: 2130ptz
  stream_source: rtsp://
  limit_refetch_to_url_change: false
  username: HA
  password: !secret HA

Hi Karl,

I like HA so far as I have seen it. In the near future I want to migrate my z-wave stuff to HA. But for now I am trying to let everything non z-weave work. I managed to do this for my Denon HEOS AVR, my LG WebOS TV and my HUE lights. The cam was my next try. It is still not working. I tried to copy your config with my specs but nothing so far.
This is my setup:

# Configuratie Grandcam
  - platform: generic
    name: Grandcam
    username: HA
    password: HA_PASS
    limit_refetch_to_url_change: false

I don’t know what to do anymore to make it work.
Do you have suggestions?


Your stream_source should be “rtsp” not “http”

Did you add the HA user to the camera’s internal users?

I guessed it should be rtsp and I tried before I replied. But I can’t get rtsp stream working, also not in VLC or the browser. Just like I put in my example it works in a browser. (It also works in Domoticz and OpenHAB).
So I am a bit confused that it would not work in HA.
I did add the user and password in the cam.

It isn’t just the “rtsp” part that is wrong on your stream_source, the part after the ip address is wrong.
Your stream source is showin “/mjpg/video.mjpg” and should be “/axis-media/media.amp”

It needs to include the port number of 554. Also just checking that your password is HA_PASS and isnt stored in a secrets file? If the password is in a separate file it will need to be change to

password: !secret HA_PASS

Try this:

- platform: generic
  name: Grandcam
  stream_source: rtsp://
  limit_refetch_to_url_change: false
  username: HA
  password: HA_PASS

I got this working in VLC:


Tried in configuration.yaml, but no luck.

The strange thing is that when I want to check f.i. the state of entities and I use the dropdown I can see a small icon that is the actual picture of the webcam. It is changing, so it must be actual. I can see it getting darker and darker.
So HA uses the image stream but I can’t get it in HA to work.

Steep learning curve for me :wink:
I found out that I manualy have to make a card inLovelace-menu. So I tried and this worked.
Because of the darkness it is impossible to see if its a still or stream picture. I used picture-entity so I guess it is a still.


I would like to know how I add a streaming picture to the menu.

I took me some hours of trying, but finaly I managed to see a streaming image.
In configuration.yaml I now have this setup:

  - platform: mjpeg  
    name: grandcam
    verify_ssl: false
    username: HA
    password: HA_PASS
    authentication: basic

Thanks for helping me.


1 Like

Glad you got the problem sorted.

Hi @karldonteljames ,

could you please also share how you have integrated Xiongmai camera? I assume that examples below are valid only for Axis as it is not working for Xiongmai…

Thank you

I found it out for Xiongmai camera:

  - platform: generic
    still_image_url: http://ipAddress/webcapture.jpg?command=snap&chanel=1
    stream_source: rtsp://ipAddress:554/user=default&password=tluafed&channel=&stream=.sdp?real_stream--rtp-caching=100
    name: DoorbellCamera

Hy and thanks for sharing your work. I had 2 Axis 241Q encoders and did follow this thread to integrate them in HA. It did not work at fist, looking at the 241Q logs I saw that HA was trying to login but credentials was no valid. I had to change the 241Q configuraiton to accept both encrypted and unencrypted password in System Options, Security, Users :

I then moved my password in clear text from the configuration.yaml file to secrets.yaml file. I was then able to replace the password by !secret myvariablename to remove the password from my config file at least. I would like a more secure way to send the password if possible. But a least, it worked!

How did you add the user:password.
I’m getting the stream, but the still image link returns error UserName or Password!

Edit: found it http://ip/webcapture.jpg?command=snap&channel=1&user=admin&password=xxxxx