Camera Live stream when loading page via url

Hi, can anyone help or try something for me.

I have had my cameras configured within Home Assistant for a few years and all are working perfectly. Still images are fine and streams from both main and sub streams can be access. I have a Hikvision NVR, and I’m using the generic camera integration. I only configure the sub streams in a low res.
I have picture-glance cards configured for the cameras in the frontend.
Everything works fine, when I click a view button within the browser the still image loads and if ‘live’ is selected within the picture-glance card the live view shows within a second or two. Happy days.

However, if i load the HA view through the browser directly via it’s url the live view doesn’t start and I only get the still image. If I then click within the browser to a different HA view and then back the live view starts.

The only reason i need this is I load a page url via kiosk browser when the doorbell is pressed. This used to work perfect up until recently.

Could anyone try the same and let me know?

You have a hikvision integration. I have a hikvision doorbell and I’m not using this integration. Maybe this can solve your problem.

I’ll give it a go, thanks

Same issue using the Hikvision Next integration, which leads me to believe its a Home Assistant problem. No Live stream on url refresh.
If you have a stream configured to show the live stream in the frontend when the page is selected click refresh on the browser and let me know if the live stream plays or you just get the still image.

I tried to reload, ctrl+F5 and this is working. I use

type: custom:webrtc-camera
url: rtsp://user:[email protected]:554/Streaming/Channels/101

But it is working with a frigate card also.

I have the axact same problem but using a Reolink camera via the Reolink integration.
When loading a dashbord (or refreshing the browser page), the camera is not streaming, only a still image is shown.
If I then navigate betwean dashboards, all camera streams are working fine. (Untill i refresh the browser page again)

Has anyone found a fix for this?

I’m also getting the same when I use the android app. Always shows link broken the first time when I try to access live streams. Second time and subsequent times (for a period) it works ok.
Reconfigured cameras. Tried using different resolutions. Tried not preloading streams. Same result.

Well I don’t know, but probably problem lies somewhere in you camera integration. I don’t use hikvision integration and never was. I use frigate + go2rtc. I know that it is a lot of work but you could try to install frigate+go2rtc and see will this issue continue.

I’ve deleted the hikvision integration and I’m trying the generic camera integration now but it’s still the same. I’m running out of things to try! :sob:
Not sure I’ve got the brain power to try frigate+go2rtc!

Well it is not that difficult. Ok it is, but it is doable.
Try this delete all hikvision integration and restart home assistant so it can remove everything including entites. And all the cameras integrations.
Than add integration again. Don’t configure anything just integration. And then test it will it work.

I stopped using the standard lovelace ‘image’ card in the frontend and switched to the custom webrtc card. That will by default also install go2rtc in the background.

Took me an evening of fiddling around with settings but happy I switched!

  • the issue of still image when loading URL is gone
  • the delay of the stream went down from ±3 sec to 0.5 seconds
  • more options (but also more complex…)

I use the reolink integration and have the same behaviour. On my testsystem which is on 2023.12.3 the card and live-view on tap works fine!
So I think as you do that it’s a HA-update-anti-feature :confused:.

Thanks for confirming. At least I can stop fiddling with the config now.
Mine used to work fine but I can’t remember when it stopped working. Question is how do we go about getting a fix for this?


As of the last Home Assistant update the problem as gone, for me at least. Can someone else verify this?