Camera.play_stream not working (RTSP Wyze cam setup)

Tags: #<Tag:0x00007f7398befdd0>

Hello,
I added my Wyze cams that have RTSP enabled with this setup

camera:
  - platform: ffmpeg
    name: Front Door
    input: -rtsp_transport udp -i rtsp://<user>:<password>@192.168.86.<XX>/live

Everything works fine and the video is really smooth

I tried to use the record and snapshot features and they worked pretty well too.
But when I tried to stream the video to my Chromecast, it connected to the device but displayed the chrome cast icon instead of the feed of the camera. I got this in my logs

Error handling request
Traceback (most recent call last):
  File "/usr/local/lib/python3.7/site-packages/aiohttp/web_protocol.py", line 275, in data_received
    messages, upgraded, tail = self._request_parser.feed_data(data)
  File "aiohttp\_http_parser.pyx", line 523, in aiohttp._http_parser.HttpParser.feed_data
aiohttp.http_exceptions.BadStatusLine: invalid HTTP method

I tried to use a different setup using the generic camera component but it didn’t work either.
My current setup uses Nginx so my base URL is not https. (I was worried it will break things so I didn’t play with it but if it does work using https I will take the risk).

I also connected my cameras through google assistant by making my own app. When I ask her to show me the front door it displays a text saying Smart home camera .

Thanks in advance for any help

@Aaliankhan did you manage to solve your problem?

I’m trying to cast my RTSP camera feed to my chromecast as well.

It just shows a loading bar and then stops.

I’m running into this problem too with camera.play_stream… What everybody else says is to set the port in the base_url.