Camera snapshot Can't write, no access to path

Hi,

not sure what happend, but I’ve updated to the latest version of core-2021.5.4 and now the path in camera snapshot stopped to work:

Can't write /var/www/i/hs/front-door.jpg, no access to path

accorind this Camera - Home Assistant it should work, as I’ve added this lines to the configuration.yaml, also the folder for proper rights for the HA user:

homeassistant:
  allowlist_external_dirs:
    - '/var/www/i/hs'
  whitelist_external_dirs:
    - '/var/www/i/hs'
my@host:~$ ls -l /var/www/i/hs
total 28
-rw-rw-rw- 1 hassuser hassuser 25802 May 15 13:14 3dprint-snap.jpg
-rw-rw-r-- 1 hassuser hassuser 0 May 17 11:52 front-door.jpg
my@host:~$ ls -l /var/www/i/
total 348
drwxrwxrwx 2 hassuser hassuser 4096 May 17 11:52 hs

any ideas ?

Hi, did you try the following ?

  allowlist_external_dirs:
    - /var/www/i/hs/

if you mean adding “/” at the end, it did not help

Has anyone solved this by now?

It appears that the basic camera.snapshot integration is now (exclusively) configured from the UI, but the perfectly good allowlist in configuration.yaml does not apply to it.

Does the UI provide any whitelisting?

the www folder works

Could you eleborate a little bit more? I tried


allowlist_external_dirs:
    - /www/snapshots/doorbell.mp4

but it didn’t work