Camera Snapshot From entity-picture

Hi there.
So I am using the eufy-ha-mqtt-bridge to bring binary sensors into Home Assistant and to view the latest image based on the last event in each camera.

This is all working fine, but I’d like to send the image from the last event in a telegram notification when someone rings my doorbell (not a doorbell camera, just a button in HA).

The last event image is coming from a camera entity camera.front_door_last_event
The image shown is the ‘entity_picture’. There is no live stream.

I’d like to just send that ‘entity_picture’ in the ‘notify.*****_tele’ service call or telegram_bot.send_photo.

I’ve tried the camera.snapshot service call, but I’m receiving this error:

Source: components/camera/
Integration: Camera ([documentation](, [issues](
First occurred: 9:27:27 AM (87 occurrences)
Last logged: 4:12:10 PM

* Can't write /tmp/snapshot_camera.front_door_last_event.jpg, no access to path!
* Can't write /www/tmp/snapshot_camera.front_door_last_event.jpg, no access to path!
* Can't write /config/www/tmp/snapshot_camera.front_door_last_event.jpg, no access to path!

As you can see, I’ve tried a couple different combinations of file paths to no avail. I’ve manually created the tmp folder in each of those locations for testing.

So I can’t seem to save the image locally.

The other problem is that I can’t send a photo via telegram_bot.
For testing, I just put a .jpg image into those folders with the same file names and when I call
telegram_bot.send_photo with

file: '/www/tmp/snapshot_camera.front_door_last_event.jpg'
target: #######omitted for privacy
caption: someone rang the doorbell

in the data section, I receive this error in the logs:

Logger: homeassistant.components.telegram_bot
Source: components/telegram_bot/
Integration: Telegram bot (documentation, issues)
First occurred: 9:45:45 AM (16 occurrences)
Last logged: 4:23:49 PM
    Can't send file with kwargs: {'file': '/www/tmp/snapshot_camera.front_door_last_event.jpg', 'caption': 'someone rang the doorbell'}

So I’m failing at both ends.

Anyone able to shed some light on my issues?

I’d really appreciate the help.

You need to add the paths to the allowlist:

This did the trick!!
I had seen this, but apparently I didn’t have my path correct when I had tried it originally.
Being on macOS, the path was the full path starting with /Users/ rather than the /.homeassistant/ folder.

Thanks so much for your help!!

Edit: In case I wasn’t clear, this worked for both issues, the saving of the photo and the sending of the photo.
Thanks again.

1 Like

Can you please share how you have edited it? I have the same problem :wink:

the path is /Users/*name_of_your_user*/.homeassistant/www/
This is if you are running HA in a virtual environment from the terminal of a mac. It will depend on how/where you are running HA and the name of the hidden folder (.homeassistant in my case) where your home assistant configuration is.