Camera woes and connecting with Blue Iris

Hi everyone, and sorry for having to bother you with what I am sure will be a simple problem to most of you.

Two weeks ago I found and loaded it onto a Rasberry Pi 3. After a lot of reading and a steep learning curve I have managed to reflash some sonoffs with Tasmota software, get them working fine via MQTT as both sensors and switches, and set up device tracking without a hitch.

What I cannot get to work however is my 2 CCTV cameras. One is a small usb SIRICAM camera, and the other an American Dynamics IP dome. Both of them are set up correctly and have the required ports opened in the router.
I have no problem whatsoever connecting to, and viewing video from them on my android phone, or via a web interface, but nomatter what I do, I cannot get video to show in home assistant. I tried everything I could think of for Onvif configurations, but nothing, and it often told me that ffmpeg was not installed ?
I know this is meant to me part of the installation, and although I can only accept that this is the case, I cannot find any ffmpeg.bin file if I look in usr/bin. ffjpeg: is in configurations.yaml

Anyway, after reading a post on here I decided to try and stream the video from Blue Iris, so I have installed that today, and can again connect to the blue iris web interface and view the cameras, but no video shown in home assistant still, despite it showing no connection faults now in the HA log, and having a grey box saying "SRICAM (image not available) on the overview screen.

In the developer states tab I can see the camera.siricam entity, and has the following next to it:

access_token: 41770aeac63ddf7566796ff970472b0adf4eae0bf681da4f9306a90aa2813c45 friendly_name: SRICAM entity_picture: /api/camera_proxy/camera.sricam?token=41770aeac63ddf7566796ff970472b0adf4eae0bf681da4f9306a90aa2813c45

and it tells me that the state is idle. I presume this means it has found the camera, but if so, how do I change it from idle to streaming ?

The camera.yaml shows:

As I said before, using the above details in a browser works fine. I have also tried using /Video instead of /mjpeg/Cam1 but still no luck.

I cannot describe how grateful I would be if anyone can tell me where I am being an idiot !


did you get anywhere with this? just moved to BlueIris as the MQTT add in is great, but cant see the camera in HA with the same issue.

have you tried alternative auth methods?
authentication: basic

i too can see the video in a browser, but nothing in HA :frowning:

adding the solution

SOLVED incase anyone else stumbles across the same problem

OK mate, thanks for at least posting a reply, I will give it a go when I get time to see if it works for me.
I thought I had read and tried most things but have lost count of what everything was !

To be honest I find there is a lot less support if you are running HA on a Pi, even threads that start off well usually end up giving instructions on altering linux files that just dont exist in the Pi software, or you need a lot more experience with linux than I have.

I haven’t turned it on for 2 weeks now as I don’t have time at the moment to try anything with it, but I’ve learnt a lot about home automation with what I did manage to do.

everyone starts somewhere - i started on a pi as well, before hassling the community and reading up :slight_smile: moved from pi HA + wink (zwave + zigbee) to just HA running on a SFF PC running ubuntu 17.10. It is annoying each bug you find, but worth it in the end

one thing to note with some cameras i found is to avoid some I/O error 0 - i specified different ports on the ONVIF and connect ports for each device.

Same issue here and it looks like it’s to do with authentication and HASS not being able to pass the credentials to Blue Iris correctly.

Ticking the “non-LAN only” only works if HASS & BI are on the same subnet and is a bit of a blunt instrument as it turns of authentication for all devices on the same subnet as BI.

In my situation HASS & BI are separated by a firewall and not on the same subnet so that didn’t work for me but I came across a different (and better?) solution which is to exclude HASS’s IP address from authentication and you do this by entering ^ (IP of HASS) in to the “Limit IP addresses” box on the Web Server / Advanced config page.