Can boot from SSD/HDD via USB, but not internal (SATA) on x86 laptop


I flashed HA OS on an SSD with Balena with a SATA to USB adapter, no problem.
If I connect the disk with the USB adapter, it boots no problem and it works perfectly (already set up).

However, if I put the disk inside, it boots straight to BIOS. The disk appears in the BIOS under SATA Configuration, but no bootable option is shown (it does if it’s connected via USB).

Secure Boot is disabled (tried enabling it too), and trying the BIOS option " Launch EFI Shell from fylesystem device" (Attemps to launch EFI Shell application from one of the available filesystem devices) returns “Not found”.

I’m using an old laptop/netbook: Asus F200CA, with an Intel Celeron 1007U, 2GB RAM. Not great but seems to be more than enough.

I’ve been trying all BIOS options I can think of, and also restoring it to defaults.
I tried the same with an HDD and with an SSD. Same thing with both.

Am I missing something? I wondered if it’s related to UEFI, but since I can boot from USB… I’m lost.

Thank you!

Edit: adding a couple of pictures of the USB boot in case they shed some light…

SecureBoot should be disabled and you might also have a CSM option that can be causing issues. If it should be off or on is a bit hard to tell, since it change from board to board, but once you figure it out by trial and error you know.

Your issues seems to be that the UEFI paths are not setup correctly.
I am not sure how HA does it, but I know other software that does it on the first run.

Try making a new install with Balena and then only boot it up in the right place first time.

If you already got a HA setup, then make a backup first so you do not have to setup HA again.

1 Like

Thanks a lot for the suggestion! I do have a CSM option.

Flashed a new disk with Balena, inserted it to SATA and tried all the combinations in BIOS, including CSM enabled/disabled. Unfortunately nothing…

Since you mention the path… I can manually add a boot option and I can choose the filesystem (image below), which looks very similar to the USB-boot path (OP photo), especially the second part. However, I have to manually write the "Path for boot option) and I don’t know if I should copy that, only part of it, or just a dumb idea. Any suggestion?

Thanks again

If you can get it right, then adding the boot option would probably work, but the path consist of the hardware path to the session, so its not the same as the USB path.
You can probably reuse the text from HD and to the end, but the first part needs to be altered.

I do not know what UEFI tools that are available on the HAOS, so I can not even point you to a guide.

1 Like

Thank you. I guess I will play around a bit more.

The same 2 disks boot via SATA on my main (modern) PC (where I flashed them on), no problem.
I looked in BIOS but can’t see the path. Also, when booting via SATA, no path line is generated in the “command lines” at boot for either disk…

In a few days I’m getting a more modern laptop borrowed and will try there and see.

I also wonder if flashing it from the same computer (USB distro with Balena, SSD in SATA) would help it make it bootable on that same device via SATA since it won’t move after flashing. Probably worthless but I’ll try…

Or if this device having Windows and then Linux messed something up for SATA BOOT for HA OS.

Anyway, if anybody has an idea I’m open to try. Thank you @WallyR for the suggestions! And I’ll report here any potential learnings I get.

My best advice is to try to update the BIOS to newest version possible and then make a factory reset after the update.
This should give you the cleanest BIOS configuration.

The update might give a few extra features and/or correct errors in the BIOS code.
The reset should remove any old artifacts from previous configurations.

1 Like

I already checked yesterday: I have the latest BIOS for it (v.208) and already reset to defaults multiple times :sweat_smile:

It works so it’s no big deal to have the USB, plus it’s hidden. It’s just a bit weird.
Will see if I solve it with the other laptop (broken screen) and can give this one back.

Thx again!!

@antonio1475 I’m having the very same issue you reported. Have you found a way out?

1 Like

Unfortunately not. I never figured it out.

In any case, I switched from that temporary netbook to a Z83V mini pc (emmc) and it works normal.

I’m having the same issue with a Fujitsu esprimo e710.
Will try to figure it out with a friend that knows more than I do.
Has anyone figured it out yet?

Time for me to chime back in. I had BIOS version 1.11.0, updated it with FreeDOS to 1.14 and 1.23 after.
Enabled CMS on the BOOT tab (last option, well hidden)(dont ask me why i did it, it was the last hail mary before i rage quit maybe). Rebooted and it worked!!!

1 Like