Can cameras be added to homekit through home assistant?

Hello! I installed homeassistant, HACS and Unifi Protect. Everything works good and I can see the cameras in the dashboard. I also have the homekit connected and even if I included the cameras in the domains, they do not appear in homekit. Am I missing something? Can Unifi cameras work with homekit through homeassistant?

1 Like

I have the same issue. No matter what I exposed to HomeKit, the cameras never showed up.

I run higher resolution camera from Reolink which also have problem sending it to homekit. However there are away to lower the resolutions and have it working. Not the best but it work.

This are my setting

  - platform: ffmpeg
    name: HomeKit Cam
    input: -rtsp_transport tcp -re -i rtsp://
      - binary_sensor.smart_bell
      - camera.homekit_cam
      linked_doorbell_sensor: binary_sensor.smart_bell
      stream_source: -rtsp_transport tcp -re -i rtsp://
      max_fps: 10
      max_width: 1280
      max_height: 1024
1 Like

Did you ever try omitting the max_fps, max_width, and max_height options? I just had issues with the amcrest AD410 that would not work over homekit at all, but adding the stream source as you have it and then adding the video_codec key to copy did the trick. Just trying to share the learnings I captured in case it can make things simpler for others.

Does you audio work? I am not able to get audio to come through.

OK so i got audio working, but it is very choppy had to use audio_codec: libopus. how is your audio?

Maybe you can share the code? since I did not get what you mean by omitting the options. Furthermore, I don’t think my camera has audio since I did not know how to add it… hahahaha

Sure thing, this is what I meant.

- name: Front Door Doorbell
  mode: accessory
  port: 21062
      - camera.front_door_main
      name: Doorbell
      stream_source: -rtsp_transport tcp -re -i rtsp://admin:<REDACTED>@
      video_codec: copy
      audio_codec: libopus
      support_audio: True
      linked_doorbell_sensor: binary_sensor.front_door_button_pressed
      linked_motion_sensor: binary_sensor.front_door_cross_region_detection

The audio I had to use the audio_codec to change it. Sadly, in HA the ffmpeg implementation seems to only have 2 options when it comes to the audio codec either use copy or libopus

hem a new coding… argh… Is this mean the front_doorbell entity connects to your home kit? I need to read the documentation… hahahahaha