Can I Disable Discovery?

Is there a way to disable Discovery?

My WEMO light switch seems to only show up once in a while so I would prefer to do everything through MQTT and SmartThings. I dont see how to ignore it in the discovery components section.

Comment out “discovery” in your configuration.yaml

# discovery:
1 Like

Wow, way too easy, thanks for the reply (and quick too)!


I did that and saved but it does not stop auto discovery.

See the notes on discovery

Depends on what you don’t want to be discovered

Comment out default_config, and add back what you need :

Could someone just tell me using quotes what I need to add to the config to get discovery to stop? I’m not a coder, so I don’t know what you guys are talking about. I tried putting a hashtag in front of the word “discovery” but that didn’t do anything. I keep getting notified about random devices being detected and I just want it to stop.

This is my configuration.yaml, but you might have different needs :

# Configure a default setup of Home Assistant (frontend, api, etc)
#default_config:

# Individual options represented by default_config
automation: !include automations.yaml
automation manual: !include_dir_merge_list automations
template split: !include_dir_merge_list template
#cloud:
config:
counter:
dhcp:
energy:
frontend:
history:
image_upload:
input_boolean: !include input_boolean.yaml
input_datetime:
input_number: !include input_number.yaml
input_select:
input_text:
input_button:
logbook:
#map:
media_source:
#mobile_app:
my:
person:
scene: !include scenes.yaml
script: !include scripts.yaml
#ssdp:
stream:
sun:
system_health:
#tag:
timer: !include timer.yaml
#updater:
#usb:
#webhook:
#zeroconf:
zone:

#includes not in default_config
python_script:
group: !include groups.yaml
sensor: !include sensor.yaml
binary_sensor: !include binary_sensor.yaml
switch: !include switch.yaml
light: !include light.yaml
notify: !include notify.yaml
mqtt: !include mqtt.yaml

I think not to have anything discovered, these are the important ones :

#ssdp:
#zeroconf:
# Loads default set of integrations. Do not remove.
default_config:

# Load frontend themes from the themes folder
frontend:
  themes: !include_dir_merge_named themes

# Text to speech
tts:
  - platform: google_translate

automation: !include automations.yaml
script: !include scripts.yaml
scene: !include scenes.yaml
#discovery

Does it matter if I put a hashtag in front of “discovery”? Maybe that was why It wasn’t working. Maybe I should just disable notifications all together while I’m at it.

Spook has a service homeassistant.ignore_all_discovered

How do I install that? The instructions are terrible and are filled with jokes that make it impossible for a serious minded person to interpret. I tried clicking on the install link but then it says I need something called “hacs” which upon clicking that link it says the page does not exist. Is there an easy way to just turn off ALL notifications? I don’t want any notifications or fancy balloon icons to distract me. All I need this app to do is to open and close a garage door, nothing more and nothing less.

Hey there! I’m having a bit of trouble trying to prevent an auto-discovery from happening on my network. I’ve been using this extension, but unfortunately, I haven’t had much luck with it.

Do you have any suggestions on how to run and prevent that integration?

How do I obtain the current representation of “default_config”?

This does not explain the lines like “automation: !include automations.yaml” or similar.

There are not part of default_config:

Ok, so the most recent list is this:

Sadly this idea was declined: