Can I install bluez & bluetoothctl on a rpi that has hassio as OS

Can I install bluez & bluetoothctl on a rpi that has hassio as OS?

Ive installed it on rpis with raspbian but never with hassio.

If you are looking to installe on HassOS, then the answer is NO.

The important question is what are you trying to accomplish?

yeah that is the better question. It was something silly really but I dont know how else to do it, im almost sure there is a simpler way w/o getting my rpi2-hassio involved, i just havent researched it yet.

I want to connect to a ble relay board and write characteristics to it in order to control the relays. I do it via python scripts. I have the board’s mac ready to connect to it, but I dont have the service. I havent been able to get the complete service uuid from any of the iphone apps i have installed, and I remember how to use bluez and bluetoothctl to do so. Thats why I wanted to know if i could install them on hassio. Before I installed hassio I did use the ble board from my rpi which has raspbian.

You don’t install anything on HassOS.

You don’t install things in running containers.

Based on your posts about you changing to hassio, you see to be having issues with that transition.

Why not continue running hassbian or run Raspbian with docker or python venv?

no, ive got hassio running fine on my rpi2. This is for mu rpi3 which has raspbian which is currently connected to an old relay board and I want to test out the new relay board but without disturbing my working setup.


I run HassOS, but I tend to agree with @flamingm0e. HassOS has bluetooth support, but it might be easier to do what you want by installing Raspbian+docker or a python venv. The other options to look at would be to look at a custom component.

“HassOS has bluetooth support” – I just installed 4.11 on a brand new RPI4 and it seems to lack bluetoothctl. I would like to use the bluetooth and BLE trackers and I thought HASS was strongly encouraging folks to use HassOS rather than HASS on top of an OS. And the hassos GIT seems to indicate it should have bluetoothctl. Confused!

HassOS may have bluetoothctl , but since you are running in a container, you won’t have direct access to it via the command line. Installing the SSH add-on just gives you a limited shell, not root access to the OS.

Copy, I’ll run Hassbian and a venv hass. Been there, done that.

Hi! I have the same issue of installing bluez on a raspberry with
I need it because Bluez tool is required on host to integrate a nespresso Prodigio coffee machine that works by bluetooth.
So how do I install it on the host?
apt install bluez?
By ssh wouldn’t it be possible?
I know almost nothing about programming. Any help would be very helpful, thanks in advance

did you get it working? I’m on the same boat, and without a clue as to how to trouble shoot it.

Nobody answer me…

It is not going to be possible, at least not without creating a container to run the code you need.

What a pity. I hope that then the developer of the nespresso integration will find a way to install bluez in, I think that most users do not have docker and do have home assistant on a raspberry.

If you’re talking about Home-Assistant (That’s what it’s called now, right?) running on Home-Assistant OS, then all of them have docker. It runs on docker.

Okay, I didn’t know that either. And then could you tell me how do I install bluez on that docker? Can I do it from the ip of the raspberry or by ssh?

Did you find a sollution for this?

Having trouble in general getting anything related to BT on my Home-assistant :frowning:

You can install BlueZ on the home assistant container inside Home Assistant OS with apk add bluez.

But that did not make the custom_component for nespresso that you mention work for me.

I’m still trying to figure out how it works I added the configuration but nothing, I don’t know if I’m supposed to do something else or that the component is just broken.

Any ideas?

Also this worked on my phone GitHub - petergullberg/brewbutton: Ardunio ESP32 BLE (&Browser Web Bluetooth) driven crappy nespresso expert brewbutton Maybe we could somehow use the code from here. Maybe

I don’t understand how BlueZ is missing from the home assistant OS if this integration makes use of it according to the documentation: