Can I integrate Hive Active Heating into HA without the Hive Hub?

@HarvsG Thanks! My Hive hub was stuck in the initialising phase and BG wanted me to purchase a replacement hub.

Using zHA I have cut over all my Hive accessories (lights, plugs. contact and motion sensors) and thanks to these instructions I now also have my thermostat in HA.

However, whilst it reports status (temp/state etc) I don’t seem to be able to control either the heating or the hotwater. Any ideas/suggestions?

Have you paired the thermostat to the receiver ?
So they both need adding into ZHA individually but they also need pairing to each other.
If not reset both so they start searching (the receiver needs to flash orange not light purple) then they should connect to each other.

Glad you got this sorted - I just checked mine and I don’t have the speech marks… yet it still works!!! I won’t fiddle with it now, but will update the post above to include them just incase anyone else comes by.

Did you get it installed? How’s it working for you?

Really interested to see how you integrate this - it feels a bit complicated to me, might need to find a way (template?) to see the last/current input_datetime so HA knows the original temperature to return to after boost is over…

1 Like

Thanks I messaged you not been great so far since hard wiring but I think that’s another issue.
Can I ask you’ve done these input_datetimes and I’ve added the sliders like you have with the initial numbers.
If I change the numbers in that card from the initial number it works bit after time it defaults back to the initial number is that how it’s meant to work or once I change the number in the card it should stay that value ?

Hi @Steveuk Indeed, that was how I paried it. I could read values ok but couldn’t manage the devices. I decided that I have had enough with Hive (would have been my 4th hub for one reason or another) so junked it for an alternative,

1 Like

Strange, mine stays at the number until i move the slider again… I’m afraid I don’t really know what is happening for it to revert to the initial numbers… is it after a HA reboot perhaps?

I’m in the market for a new way to control my central heating and hot water and I’m trying to avoid any system that has cloud dependencies.

I already run zigbee2mqtt so hive looks like the way to go.

Reading this thread I just wanted to clarify a few points.

If I get the SLR2 on its own can I use one of my temperature sensors in home assistant and use it with the generic climate component?

If I get the SLT as well, is the temperature it reads available in home assistant?

Again, if I get the SLT and I adjust the target temperature in the home assistant ui, is that reflected on the SLT?

And finally, if my internet goes down will this keep working as normal?

Thank you

As far as I know, unless something has changed recently, you need BOTH the receiver and thermostat. the receiver reports the temperature, but it actually comes from the thermostat - I think there’s some direct communication between the two. I guess there may be a way to send a MQTT payload to the receiver from your server, but this direct communication isn’t documented and is way above my ability to find!

Yep, but as above, its a bit strange, the receiver reports this as local_temperature.

Yep, it all works two way. The boost mode is a bit finicky to get to work, but @Steveuk and I have both implemented this.

Yes, if you connect the SLT and SLR to your z2m instance it works direct. I’ve not got, nor have ever had, the hive hub.

Scheduling is a bit fiddly, there is a schedule mode on the thermostat, but this doesn’t play nice with HA control… see a long post further up the thread where I’ve set this up - you could also try something like Schedy.

Overall I’m pretty happy with the hive thermostat/receiver now, though, now I understand more (and am much much better at esphome than I was) I might next time go with an ESPHome relay instead…

The redeeming feature of this hive system, in my head at least, is that if my server goes off, i lose local wifi/z2m/everything goes wrong… at least then the SLT and SLR are still working together…

1 Like

Ahhh, that makes sense, thank you

For scheduling I was going to try using the google calendar component orchestrated by nodered to control everything, which is something that worked really well for me with my esphome based boiler control system in my old house.

Is that likely to work here do you think?

This is exactly my train of thought as well, that plus it’s easy for the wife to use

In terms of buying this, Hive have the “Hive Active Heating without Hive Hub” available for £99 from their site but it’s not clear what version of the SLR is included…

Is it better for me to source this from ebay as others in this thread have done?

I really appreciate your quick reply. Thank you

Yes I think it should, I haven’t used NR but I think it should be fine if your automations can send this mqtt payload to the receiver:
{"system_mode":"heat","temperature_setpoint_hold":"1","occupied_heating_setpoint":"DESIRED_TEMPERATURE"}

I got mine separately on eBay, I think they were about 15 each plus postage, whole thing was less than £40! Just had a look and there’s a few on there now at similar prices.

Nothing much I can add as @vonagio covered it all.
I’m really happy with mine also ,it’s been working perfectly for about a month now,
I dropped really lucky on eBay as was wanting a second set besides my wired in hive to do the testing on and I found a old British Gas branded version receiver and thermostat £10.50 for both.

That’s insane! tbh I’m perfectly Ok with spending ~£100 but the new model numbers don’t show up as supported in z2m so it would be a bit of a gamble.

I’ll monitor ebay for a few days and see if I can get lucky

What model numbers are showing as the latest I can’t find them on hives website ?
Sometimes it’s only a cosmetic change or branding etc but the actual device is the same so may be able to add it as a external converter.

SLT3c and the only difference seems to be that it has capacitive buttons. There’s no information on the receiver.

I might just ‘take one for the team’ here and order it.

1 Like

I’ve recently purchased a hive v3 and I think I’ve successfully integrated it with zigbee2mqtt. I’ve just added some PR’s to the herdsman and the docs. Hopefully if I’ve submitted the updates correctly it’ll be rolled out soon!

1 Like

Nice! Thank you. I’m still waiting for mine, they’ve been waiting on stock for over a week. It is on its way now though.

My v3 is up and running using the Z2M dev branch. I’ve adapted vonagio’s config above to work with the dual channel receiver and the heat is up and running. I’ll have a go at getting the water working tonight.

I’ve started putting my nodered flows together as well but controlling the HA entities rather than going to mqtt directly. The only problem I had was sending multiple commands at once, eg temperature and heat on commands. It works fine once I set a 5 second delay between the two commands…

One thing I’ve noticed is that the thermostat is quite glitchy and often says ‘no signal’. Has anyone else seen that? it’s possibly something to do with my setup but I don’t know what it could be, my mesh is working fine otherwise.

Last update from me, I installed this over the weekend and it’s working great so far. The ‘no signal’ problem I saw has disappeared so I put that down to the mesh settling.

Hot water is controlled with the google calendar integration and the heating is controlled with presence and a few other inputs.

Thanks for all the help.

1 Like

This thread gave me the confidence to go ahead and set up this system for myself and Im pleased with the results so thanks for that. I have one question for someone who might have already encountered this problem im having however:

When I set the heating mode to off using the HA climate entity created by Z2M "system_mode_heat": "off" is set correctly. However if my target temp is above the local temp heating still takes place. I see that I need to set "temperature_setpoint_hold_heat": false at the same time as changing the mode in order for this to work as I intend.

Is this intended functionality, shouldn’t HA also set the second part to false and respectively back to true when you switch back to heat? Otherwise having a temperature schedule set up is somewhat harder to disable when you go away, when really pressing ‘off’ should ensure any high temp is ignored?

Is there any way to customise this default behaviour?