Can I just have a vent here? Please skip if you need to

Hi folks,

So let me be straight up:

  • I’m no *nix guru
  • I’m not a total noob
  • I’ve had fair bit of experience with HA
  • I love HA!
  • I want to move to a x86 based install of because:
  1. I love the idea of a hands off HA install
  2. The plugins are just what I need, not being a *nix guru

So. I have an install of hassbian on a Pi. It’s fine and all - but I think it needs a little more muscle. I have left it doing house duties while I look to a nuc based install. I have a nuc device (ok, it’s nearly a nuc - it’s a corei5 Lennovo ThinkCentre).

I had running on it for a while. I booted it up one day to find that it started up, but did not have HA responding. The logs show that HA had started, but no errors. Fine I thought, lets start again. SO I reinstalled. Boot? Good? Fine - lets install samba and mosquitto. Reboot - no response from HA. Damn. OK, maybe there was a collision with the built in mqtt and mosquitto? Fine, we can just reinstall. Boots! Nice! Oh look - there’s an update to .75… sure, let’s do the update. Reboot. Oh, would you look at that - NO REsPonSE. Again. 3 times in 2 days.

Please, give me strength.

This is not a pointed complaint at anyone. The people who have put it together are legends in my book. Yes, I’m not the target hardware, but I can’t even look into whats broken? This is all I get in a fresh log file:

2018-08-04 02:34:54 WARNING (MainThread) [homeassistant.components.http] You have been advised to set http.api_password.
2018-08-04 02:34:55 WARNING (Recorder) [homeassistant.components.recorder] Ended unfinished session (id=5 from 2018-08-04 02:20:41.912230)
2018-08-04 02:34:58 ERROR (SyncWorker_17) [pychromecast.socket_client] Failed to connect, retrying in 5.0s

I’m frustrated and lost. I really don’t know where to look or what to look for.

Anyway, rant over. Thanks for reading.

Here is my rant.

A year ago I tried various installs of Hassio, and eventually followed the BRUH video for, even though it seemed like all help and instructions were only for Hassbian type installations. I used it for maybe a year, but the last “update” to SSH & Terminal (or whatever they were, it’s been such a frustrating week trying to get anything to work again that I can’t even remember) crashed it. I followed instructions by first deleting the “deprecated” addons, which previously worked great. After reloading, the two new versions wouldn’t work, and I got annoying “no password” errors, even though I entered passwords (I eventually tried every password format I could think of).

Finally giving up on the “improved” addons, I tried loading a previous snapshot. That completely hosed, and I couldn’t even get it to load.

So, I downloaded and tried the latest regular version, but there was no easy way to get to the configuration.yaml, or otherwise configure it. Worse, now it seems like all the various online help screens and instructions are mostly for, and not hassbian (the oppostie of what I experienced when I first started out).

So, I downloaded the latest 32 bit version, loaded it, and eventually it gave me the main screen. But there is nothing under the tab. It is blank. I tried rebooting, restarting, and so on. Nothing worked, and the tab is still completely blank. So it is impossible to get any of the crucial add-ons.

Now I see countless problems in the forums. Mostly they say that things that worked great before were now “improved” to the point where they no longer work at all. So, after a year of using it, I am just giving up. I can’t count on Home Assistant to work consistently any more, since every new update introduces problems, and I am tired of trying to fix them all.

I’m not going to post logs, or jump through any more hoops. I used for a year, everything worked great (MQTT, SSH, Samba, Terminal, DuckDNS, sonoff devices through Amazon Echo & Google Home, and so on). All that work and experience is now pretty much useless, as they no longer work, and I can’t even get a basic configuration to work any more.

Have you thought about learning some basic Linux and not using hassio? Home assistant in Docker works beautifully and mine has been stable for over a year now. Updates are a single command away, with no dependencies issues, no weird python environment switching no fuss.

docker-compose down && docker-compose pull && docker-compose up -d


Couldnt agree more, reading @flamingm0e and @CCOSTAN experiences with docker convinced me to move to it. stable and so easy to upgrade/downgrade when needed. i can even test out dev releases if i want

+1 for docker

1 Like

Yes, I even tried it yesterday in a way. To be clear though - I want I want the add-on experience, I want that one click install of grafana, node-red etc… I don’t want to learn each of the"back stories" of these apps and others to get running. I don’t want to give them my time just learn how to install them.

I followed another thread on here - on installing Debian & then proxmox. I then tried to run the virtual appliance image of, no luck. Then I tried a straight install of proxmox, a small Debian image, and then tried to install docker. No luck.

It just needs to get simpler. It really does. It’s getting harder, not easier.

I’ve given up on the idea now. I’m so f#&+ing frustrated with it. I don’t mind telling you I almost threw the PC across the room. Bloody infuriating.

To boot, the thing that motivated me in the first place is an incident where one sleepless night in bed I rebooted my Pi install of hassbian. It didn’t shutdown. It just hung there. It left me stuck there with aircon running too hot in the bedrooms and no way to turn them off (yup, I’ve committed to HA). I had to do a nude run downstairs three stories, in winter, to the garage to physically reboot to pi.

And that is beginning to sound like an easier thing to live with.

1 Like

Coming back to your wish for more muscles, maybe you tell us which Pi you use?
I’m currently running HassIO on HassOS on RPi3 and the performance as well as reliability is pretty good for me.

Did your promox install work? I have hass image running in proxmox and it works great. Let me know if I can help.

So if something goes wrong with one you want no way of troubleshooting it, so you can come back here and “vent” about how your node-red crashed and you need someone to fix it now?

This is completely the wrong attitude to have when working with open source projects…

1 Like

A pity this thread is now polluted with a fitty.
Rants and vents very often have valuable feedback to create a better UX for non-techies and techies alike.

For the update to 0.75, your timing was very unlucky because there was a bug not showing the HAssIO tab…

Thanks mate. Yes, read all about that one. Unfortunately I wasn’t even getting that far!

1 Like

For relying on HA, it is better to have a production environment (your Pi for instance, which has been running for a year you say) and a test environment.
Best to have a Pi for that as well.
Also, do not update straight away with a new version but wait a while to see if there are any major issues.
You do not have to be an early adopter. I very often wait a week before updating

edit: sorry, you do not mention a year :smiley:

1 Like

My production version is to be the install on the nuc. The goal posts moved during the whole ordeal to a state where I would like to have two VMs running on the nuc, one for Dev and one for Prod. The Pi is just not as snappy as the nuc. The pi also has a SSD in a USB case to boot from, makes more sense to have that SSD in the nuc. I’ll liberate the pi for other creative adventures.

I’ve been playing with this stuff for at least 2 years! Love it! … Usually…

1 Like

A, I see :slight_smile:
That is a good idea indeed! I keep close to the hardware used in general, I have a Pi3+

HA is a very fast changing platform, which has pro’s and con’s.
That’s why I do not install an update straight away, in every release there are breaking changes and major issues or solved as quickly as they appear.

But in your case I can completely understand your frustrations, I think everyone has had them at some point.

While the platform has an enormous potential, I think it would be better to focus on all the issues now instead of adding even more features. But maybe we have to see when HA reaches 1.0

I hope you will still give it a shot, every user is valuable :slight_smile:


I agree, the platform has enormous potential, which is why I personally continue to lurk here. I also have lots of bits of hardware (Pi, a Hue, some Aeotec, Wemo, even some Sonoffs ready for me to attempt putting Tasmota onto them) that I am experimenting with when time allows, in an attempt to get some sort of environment operational.

But I also agree that this platform is just too hard at the moment. It requires way too much research and learning in order to get even a basic setup operational. Instructions are sparse, uneven, contradictory and out of date. The forum is not helpful, as people are touchy and assume everyone should be a coder, which is weird as the project seems to want to ultimately become an appliance. There seems to be no regression testing, and just an accepted fact that a release will break things. Foundational aspects seem to be created and recreated on a whim, which further break things or require dependent services to be redeveloped, both of which are wasteful outcomes.

It is all very well for people to say “you should have a test and production environment”, but where is that spelt out for newcomers? Where is the list of prerequisite hardware, software knowledge, coding aptitude, troubleshooting skills, available time for troubleshooting, newbie-beginner-trainee-acolyte-skilled-advanced-master skill evolution, for people to know whether this is for them or not, etc? Where is the tech and feature roadmap for future developments?

My day job is a business analyst, tech writer and UX specialist, and from what I’ve observed those skills are really needed to take this project to the next level of maturity, but frankly after watching this forum on a daily basis for 6 months my hope of this project ever evolving to welcome people with a nontechnical background continues to decline.

Open source is not the same as lazy architecture, and community-built is not the same as unplanned vision state.

My opinion is that until such time as some serious future planning is performed, communicated and bought into by the community, this project is going to continue to have a lot in common with the Wild West. (And we all know how that ended up…)

1 Like

Yes, that is what is missing indeed.
Compared to a CMS like Joomla, which has Long Term Support released and Short Term.
A similar system could be implemented, where LTS would be for non-techie users.
LTS should be tested out so a uses is not blown out of the water after upgrade.

1 Like

Hey man, I feel you. Right now I have time to read the forums and fix the issues that pop up, but if I was back on a regular work schedule and fixing Home Assistant during my precious weekend hours, I would be frustrated. When you look at the number of features and components added to Home Assistant compared to Smartthings, it is unmatched, but now you see why Smartthings doesn’t add new integrations often (stability vs. features).

Home Assistant is amazing (especially Lovelace), but I would never recommend it to anyone as their first home automation system. You will need to make a decision soon…keep your sanity and free time or keep playing with Home Assistant. I will eventually stop upgrading my HA instance and see how long everything will keep working. I’m hoping it’ll last for a year :slight_smile:

You could always come back to Home Assistant a year from now and see if things have stabilized.


+1 to that and to the LTS idea. With a full time job and young family, HA is a fun hobby distraction, an hour here or there to play around with new integrations. But when my very limited time is all spent playing catch up with the latest changes, it loses it’s ‘fun hobby’ status and becomes a chore.

Spent the last week trying new firmware on my router, so that it supports nginx and I can implement reverse proxy for a bit more security. Meanwhile mosquitto has died and we’ve lost our presence detection, so now my phone keeps ringing with an ‘unauthorised entry’ message.

I think it’s easy to take frustrations personally working on an Open Source project, hence the often seen “if you’ve got an issue with it, fix it yourself”. There are a lot of people committing a lot of time to this project, and I assume everyone wants to see it grow into a large, successful endeavour, which will necessitate at some point tackling accessibility and stability. If HA doesn’t, someone else will, because it’s a hot area.

We’re all part of the same team, my role is “early adopter and feedback giver”. Perhaps not as sexy as developer, but the more people there are in this role, the better HA can become!


This is one of the best #1stWorldProblems I’ve read in a while. The only way I can think of cranking it up would be to mention having to move the Teslas around in the garage to get to the Pi to reboot it.

Joking aside, I do wish the HASS.IO was a bit easier on the instruction side for Docker specifically. I think for the PIs, it’s pretty good but trying to figure out how to run it on any other platform can be quite challenging. I’ve been struggling to help friends that are trying to get it up and on NUCs or OLD Laptops. I really see the appeal in the 1 click addon store as well. that’s why I push many of my friends who ask to the HASS.IO version rather than full blown like what I run.