Can I run deConz and zigbee2mqtt at the same time with one Conbee II?

The YT tutorials I used to install z2m was old, pointing to the wrong location for the repository.
ATM you need:
My Z2M was 1.18.1-1 and it didn’t update.
Now I have installed version: 1.25.1-2 and by the time it had been installed, it had already found all of my wall switches and appears to work

I’ve migrated from deConz to z2m and most things are now working.
But none of my Aqara UK “No Neutral” H1 switches or remote switches is recognised, even though they are in the list of devices that work with z2m.
I’ve tried to understand the instructions for adding unrecognised items but it’s not making sense to me.
So, is it possible to reinstall deConz pointing to the same Conbee II, and then add the wall switches to that?

These are what I have:

  • Aqara Smart Wall Switch H1 (No Neutral, Single Rocker)
  • Aqara Smart Wall Switch H1 (No Neutral, Double Rocker)
  • Aqara Wireless Remote Switch H1

This is what is reported:
Friendly name 0x54ef4410001af0bb
Device type EndDevice
Zigbee model lumi.remote.b28ac1
Support status Unsupported
IEEE address 0x54ef4410001af0bb
Network address 0x9CA7
Firmware build date 20200907
Firmware version 2019www.
Power source Battery
Interview completed Yes

Friendly name 0x54ef44100022420f
Device type EndDevice
Zigbee model lumi.switch.l1aeu1
Support status Unsupported
IEEE address 0x54ef44100022420f
Network address 0x3B9C
Firmware build date 01-12-2021
Power source
Interview completed Yes

Friendly name 0x54ef44100024574a
Device type EndDevice
Zigbee model lumi.switch.l2aeu1
Support status Unsupported
IEEE address 0x54ef44100024574a
Network address 0x9174
Firmware build date 01-12-2021
Power source
Interview completed Yes

No, only one. If you have one more Conbee, you can have both running at the same time. One for Z2M and one for Deconz.

I do not have the switches you mention, however they should work in Z2M. Have you tried to remove then and re-pair them? Maybe the switch can be “factory reset”, it might be remembering something form the Decons setup?

Thanks for taking the time to respond khvej8, I suspected you couldn’t share a serial port but was worth asking.
Yes, these switches are a mystery. For pairing (and resetting I believe) you hold them closed for 10sec, then the LED briefly flashes orange then a number of blue flashes, then you let go. They then pair but claim to be unsupported :frowning:
I’ve tried repeatedly removing them and re-pairing them over the last week, no joy sadly.
You may well be correct in that it could be a leftover from the deConz days, but I am clueless as to what else to do.

I ditched the DeConz and switched to Zigbee2MQTT and never looked back.
Also ditched the Conbee II for a CC2652P stick.

1 Like

@HemiBob have you looked into actually seeing if there is a separate factory reset you can do, not just restarting pairing. It’s possible there is a difference between just putting the device back into pairing mode versus it getting factory reset with no trace of prior(Deconz) configuration. Seems there is a long thread about the H1 Switch in regards to it being setup with ZHA that might give you some more hints.

Yes timnolte, I’ve searched but not found one yet. I’m going to turn the supply off for a while and see it they forget their past life. I might buy a fresh one and see if that shows as supported.
So frustrating, at this rate I may give up on z2m and go back to deConz :frowning:

From what you’re sharing it seems like they should be supported. The interview seems to have fully completed and the model number matches up with what’s in here:

(at least for the single rocker, I didn’t specifically check the others but I assume I’ll find the same)

I’ve had plenty of issues getting my xiaomi aqara devices to pair to a network after they’ve already been paired to one so I definitely feel your pain. I don’t know who’s brilliant idea it was to omit a button/pinhole for factory reset from these devices but, well, I don’t have anything nice to say here so I’ll just say it was a poor decision.

That being said, my problem is usually getting the interview to complete. I’ve never had it complete and then just stick on unsupported like that. It’s possible you found a bug or there’s some additional pairing steps for those particular xiaomi aqara devices that’s not properly documented. I would recommend asking about it on the Z2M discord.

I’ve just been starting out and it and decided on Z2M since a lot of reviews seemed to point to better support for more devices. I hope I didn’t end up starting off on the wrong foot. So far all of my ZigBee devices have worked without a hitch. Time will tell as I continue to build out my smart home.

1 Like

Rest assured you made the correct choice, Z2M is a great way to go. Followed by ZHA. Followed by nothing really…


Thanks, CC, withing an hour or so, the answer appeared.
My z2m was so old, but didn’t offer an update so I had no idea.
That’s the problem with following old YT tutorials.
I’m a happy boy now, thanks to all who posted on here :slight_smile:

Can i ask how do you update Z2M as im having the same issues with the same switch

I switched as well from deconz to zigbee2mqtt (with a conbee II stick). It wasn’t a walk in the park. Some of the aqara sensor took a lot of reties to work with zigbee2mqtt. I feel it was worth it (mainly for the lixee tic that didn’t want to work with deconz, but for the big community around z2m)
My question is : I still have deconz installed but disabled on my HA. Is it usefull to keep deconz installed for firmware updates of the conbee II stick or can I get rid of it now?

If you stick to the Conbee II then keep DeConz for the firmware updates.

But honestly I would consider ditching the Conbee II as it has a weak and outdated chipset.

Better get some decent Zigbee coordinator based on the CC2652P chipset like ZigStar4 or SonOff.

1 Like

Thank @anon94216691 for the anSwer. I’ll plan to do so!

Can I easily use DeConz for updates and not mess with Z2M?

Hi @HemiBob, from your OP it seems that your issue is solved.

Please take the time to mark the answer as solution, you do that by selecting the three dots under the post:


Then select the check box:


This can be useful to other users as well and prevents that someone else steps in to try to help you.