Can I upgrade from HassOS v1.13 to v2.8?


#1

It appears that HassOS v2.8 is marked as Stable on github, so I’m tempted to update from v1.13 which is currently working well

Can I ask what the best way to upgrade would be?

Just log in to ‘Hass.IO’ tab on homeassistant and click ‘update’ under ‘host system’?

Or would it be better to back up my config/snapshot, and start with a fresh install?

I’ve used the update in the past, from 1.11 to 1.12 worked OK, but I was unsure as going from 1.x to 2.x may have some breaking changes.

Thanks

EDIT: I should say that I’m running on a RPi 3, 32bit build


#2

Theoretically yes. I and a couple of other people have not been able to do it this way. Give it a try and report back here (it won’t break anything if it fails):


#3

I did upgrade from 1.13 to 2.8 just by clicking update in the GUI and it worked fine.


#4

Same . No problems here


#5

…I dont get it. Is HassOS the ready to burn image including hass.io? :roll_eyes:

EDIT:
forget my question…
giyf New Hass.io images, based on HassOS


#6

Must have been a temporary thing, or fixed. It now works for me too.


#7

Thanks for the replies, after backing everything up I did the update, and rebooted and it’s now running v2.8 without any apparent issues so far :slight_smile: