Can no longer use sudo reboot effectively on the new Hassbian image?

Hello all, So yesterday I updated to toy-box and now instead of pi@raspberrypi im pi@hassbian.
I was wondering if this comes with new privlages or lack of, because when I go to sudo reboot which I do time to time to get the config to update because sometimes the restart service doesnt work along with the restart HA command. anyways, I now get this.

pi@hassbian:~ $ sudo reboot
sudo: unable to resolve host hassbian

Then after more then a few minutes it’ll reboot, instead of instantly.

Broadcast message from pi@hassbian on pts/0 (Sun 2017-02-05 12:01:28 EST):

The system is going down for reboot NOW!

which isnt really convenient since Im a new guy trying to get his yaml to work correctly and it makes the process a lot longer. Anyone else having this issue on the hassbian image? am I just missing something obvious? Thanks

Is there any difference if you use this command?

sudo shutdown -r now

I still get:
sudo: unable to resolve host hassbian

and it basically is locking me out my pi for several minutes unless I unplug it. very strange.

I don’t use the HASSbian image and I know they just rebuilt it so I’m not sure why. I recategorized your post into the HASSbian category in hopes of you getting a better answer.

The effort is much appreciated. Im going to keep trying different things to see what the deal is.
I only use the hassbian image because for whatever reason the other install methods just dont work correctly, for me at least.

You might want to check your hostnames file. If you try to ping hassbian, do you get a proper response?

If not, you may want to look at this thread. It’s for Ubuntu but the issue seems related.

It pings just fine. How do I check the hostname file? is there a way to make the hassbian host like the raspberrypi host to work around it maybe? Again ive only really been getting to into the grit of HA for about a week or so now, if that sounds silly forgive me.

If you can ping it successfully, then there’s no reason I can see to start mucking around with your hosts file, but the location should be etc/hosts if you want to look at it. A good tutorial on the host file can be found here:

(Don’t worry about sounding silly - we are all new to something. I am still learning new things every day with HA, partially in researching answers to other users questions!)

1 Like

BTW, let me know what you find - I’m curious.

I think I had same issue initially, but it was resolved once i set the hostname through the raspi-config tool ->advanced options-> A2 Hostname

pi@hapi:~ $ > sudo raspi-config

┌────────────────────────┤ Raspberry Pi Software Configuration Tool (raspi-config) ├──────────────────┐
│                                                                                                     │
│        A1 Overscan     You may need to configure overscan if black bars are present on display      │
│        A2 Hostname     Set the visible name for this Pi on a network                                │
│        A3 Memory Split Change the amount of memory made available to the GPU                        │
│        A4 Audio        Force audio out through HDMI or 3.5mm jack                                   │
│        A5 Resolution   Set a specific screen resolution                                             │
│        A6 GL Driver    Enable/Disable experimental desktop GL driver                                │
│        A0 Update       Update this tool to the latest version                                       │
│                                                                                                     │
│                                                                                                     │
│                    <Select>                                     <Back>                              │
│                                                                                                     │

changed the hostname back to raspberrypi and I’m still getting the buggy responce to “sudo reboot”
now it just doesnt say “unable to resolve host ect” yet still acts as if its trying to run the command sense it wont let me run any other commands and leaves me with no choice to unplug it.

My sudo reboot tends to take about 3+ minutes before it finally reboots. I assume its waiting for some process(es) to finish off.

Does reboot -f make any difference? It goes down pretty quick for me. I don’t know if it will cause data corruption.

its still taking more then a handful of minutes, ie I typed the command 3 minutes ago and it hassent (haha get it) even gone down yet. I just wonder why its taking so much longer now, before toy-box i could reboot and be back up in less then 30 seconds…

just want to keep this alive! same problem here loaded the new hassbian image and even though samba lets me connect it will not let me edit files. It says the file is open somewhere else or something i also get the sudo: unable to resolve host hassbian message as well

I’m still getting the error after I use “sudo” for anything and I haven’t seen anything else about this issue yet.
Maybe its just a bug with the new image, I thought about re-installing but my HA instance is working fine. So I dont see a huge reason to since its only a big hassle when trying to reboot, yet still is a hassle in its own.

I’d suggest putting in a github issue at this point. Whomever does so should post the link here so that the people involved in the thread (an anyone who comes along later) know where to go to post their findings.

I also had the same problem with samba at first so I re installed the image and and now samba comes integrated in the HA image so I ran:

sudo ./hassbian-scripts/

after editing my config everything was working fine as far as file sharing goes.

1 Like