HASSbian not working out of the box

So am going crazy here, firing up a hassbain on Pi on ethernet, boots, does first install, WebGUI load. Connect via SSH, add base configuration - whip power out, pop it back in and wait, and wait, and wait - nothing! Scan LAN with FING, Pi is on the network. Scan services, only SSH ports open. NO Web GUI - when i brows to http://PI_IP:8123 in chrome I get “Connection refused”.

He remiage multiple times and same behaviour each time - any suggestions very welcome about now as starting to lose my mind.

Many Thanks!

Not sure if this helps but i get these errors to a few commands…

pi@hassbian:~ $ systemctl enable [email protected]                                                          

Failed to execute operation: Access denied
pi@hassbian:~ $ systemctl start [email protected]
Failed to start [email protected]: Access denied
pi@hassbian:~ $ hass --script check_config
-bash: hass: command not found
pi@hassbian:~ $ sudo su -s /bin/bash homeassistant
sudo: unable to resolve host hassbian
homeassistant@hassbian:/home/pi $ source /srv/homeassistant/homeassistant_venv/bin/activate
bash: /srv/homeassistant/homeassistant_venv/bin/activate: No such file or directory

You’re not the only one. I just installed Hassbian 1.1 from 2017-02-03-HASSbian.img and it didn’t even look like HomeAssistant was installed on it. Same as @oderuyter

1 Like

Well I know its there as seen the GUI, but no services appear to be running and no webGUI - maybe I’ll try a slightly older build

I was able to track down a potential fix. It appears there is something wrong with the hass setup in /srv/homeassistant/bin/hass. I found that running hass interactively was working as both pi and homeassistant users. Finally I ran which hass and found the location was /usr/local/bin/hass. Updating the service entry as follows resolved the issue:

/etc/systemd/system/[email protected]
# This is a simple service file for systems with systemd to tun HA as user.
# For details please check https://home-assistant.io/getting-started/autostart/
Description=Home Assistant for %i


1 Like

In case anyone else is annoyed with the message

sudo: unable to resolve host hassbian 

I noticed that /etc/hosts contained raspbian
changed this to hassbian
and the message goes away.


Had the same issue. Sam’s fix worked for me.

To be able to make the change, though, I had to be directly connected to the pi; PuTTY/SSH would not allow me to make any change without changing the default password first. And I couldn’t change the default pwd SSH’ed to the pi. So, the steps I took:

  1. Plug monitor and keyboard to the pi.
  2. Change default pwd.
  3. Edit /etc/hosts as instructed by Sam.

any solution ? i have the same problem

I binned Hassbian off and put Raspbian on and used the all in one installer

did use jessie lite ?

Can anyone dumb this down for me a bit further? What exact file do I need to change? Also do I simply include the given text or are there some lines I will need to leave.

@Redwards I’m also new to raspberry pi. I can walk you through how to change the file, but unfortunately it didn’t actually fix my problem :frowning:

Disclaimer: I apologize in advance for my rudimentary language describing everything, like I said I’m new at this.

Basically what you want to do is type in:
sudo nano /etc/systemd/system/[email protected]

“sudo” is what gives you permission to go into various files. “nano” is kind of like opening a document in Microsoft Word. It is a thing that lets you edit files.

Then all the code that @rchiarelly put will show up. I pasted it down here again for your reference:

# This is a simple service file for systems with systemd to tun HA as user.
# For details please check https://home-assistant.io/getting-started/autostart/

Description=Home Assistant for %i



Basically put a “#” in front of where it currently says “ExecStart” and then make a new line and put in “ExecStart=/usr/local/bin/hass”. The “#” makes it so that the computer will skip that line, but if you needed to reference what you changed in the future it’s still there.

Then do CTRL+X and type “y” and the hit enter. This exits the program, says “yes” I want to save it, and then confirms that you want to save it in the same place.

This did not solve my problem though! Has anyone figured out where “hass” is located on the all-in-one installer? That’s what I’m using.

1 Like

Thank you. That makes much more sense. I am currently trying a clean install with the AIW installer.

Thanks Sam!

That fixed my issue as well.
The suggestion from EmilyBoda doesn’t work on the Hassbian image.
I had to roll back the change and restart the PI.


I’m also having trouble. I’m on a mac and used the dd command (as described here) instead of “Etcher” to flash the HASSbian image to SD card.

I’m running the Pi headless (no display!) and it seemed to work ok but after booting the Pi (connected via ethernet cable to my internet router) and leaving it overnight, I can’t get the HASS web interface to load. When I use a LAN scanner, it finds Hassbian at but only the SSH service (port 22) is running. There is no 8123 port!!

Any suggestions? Thank you.

One more thing, I can login via SSH but when I type “ls -l” there are no files visible! When I “cd” to the path rchiarelly suggested, it does change to that directory - weird. I also tried @rchiarelly suggestion to edit the hass setup file, but this didn’t help.

Forgot to ask, I don’t actually need to SSH in and manually start the “homeassistant” service do I?

Same boat here.

Has there been any updates to this issue on the out of box install.

I’ve also tried the Daemon instructions, and the error I get in the log says it can’t find service “hass”.
Tried “root” “user” “hassbian” “(hassbian) hassbian” “pi” in the user field

Losing my mind along with @oderuyter

Hassbian loads fine if I ssh in and do the following

sudo su -s /bin/bash homeassistant
source /srv/homeassistant/bin/activate

But if the SSH instance is closed, paused, or anything of that sort, hassbian turns off.

I have a few other ideas to try, but as a complete unix/raspberry pi/terminal newbie, I think I might just be chasing mythical options.

Same problems here, can’t connect to home assistant following the complete istructions on the website.
This is kind of shame and hope it gets fixed soon: I’ve been using HASS for some time and I’m in love with it, but these hassbian issues could potentially make new users look for alternatives. Just my two cents…

Just installed HASSbian 1.1, and had (I think) the same problems as others here – Pi booted fine, I could ssh in, but HASS wasn’t running.

I noted a message in syslog about not finding some YAML library. So I did a:

sudo apt-get install python3-yaml

and waited for it to install, then rebooted. Lo and behold, when it came back up, it completed the HASSbian configuration, and after ~10 minutes (doing ‘ps axuw’ to see what was going on; I have no screen on the raspi) it came up with the web interface.


Im getting the same problems… what was the solution?