Can not add Xiaomi vacuum / Retrying in background

each time i try to add my vacuum over the gui there is an error.

"Config entry 'Michael' for xiaomi_miio integration not ready yet; Retrying in background" but it is never getting ready.

How can I fix this?

Thanks in advance.

1 Like

Please provide some more details.

Which model of vacuum do you try to add?
(there are some known prerequisites for some roborock models to work correctly)
Which version of home assistant are you running?

Have you tried to enable debug logging for the component & miioprotocol to see whats going on?

    homeassistant.components.xiaomi_miio: debug
    miio.miioprotocol: debug

And for sure welcome to the community - Just saw you are a new member :wink:

Thanks for the welcome :grinning:

Below the system information:

System Health

version: core-2021.12.9
installation_type: Home Assistant OS
dev: false
hassio: true
docker: true
user: root
virtualenv: false
python_version: 3.9.7
os_name: Linux
os_version: 5.10.63-v8
arch: aarch64
timezone: Europe/Berlin

logged_in: false
can_reach_cert_server: ok
can_reach_cloud_auth: ok
can_reach_cloud: failed to load: timeout

host_os: Home Assistant OS 7.1
update_channel: stable
supervisor_version: supervisor-2021.12.2
docker_version: 20.10.9
disk_total: 14.1 GB
disk_used: 4.3 GB
healthy: true
supported: true
board: rpi3-64
supervisor_api: ok
version_api: ok
installed_addons: Node-RED (10.3.1), File editor (5.3.3)

dashboards: 1
resources: 0
views: 1
mode: storage

It seems to be this line:

 [homeassistant.components.xiaomi_miio] Finished fetching Michael data in 10.113 seconds (success: False)

One more thing it tries to connect to the IP ending 101 but real IP is 148.
The tool for getting the secret shows also IP 101. Why the IP on the xiaomi cloud different to the real one.

It is the model roborock S5.

Are more informations required?

Solved. I chose the wrong region.
Thanks for your help.

Great you found the solution by yourself :+1:

Where do you select/change the region? I am having this same issue.

The region is selected during integration setup config flow.

Is it possible the region setting is lost eventually? Periodically I get this error and I have to remove and re-add the integration because even after days and many restarts it never recovers.

Dear Developers,

I have a same problem with my XIAOMI robot vacuum cleaner
I have the oldest xiaomi vacuum v1 machine, which is on “de” region.
I tried to add manually with correct account name (emailaddress) and password , region and API token ( comes from token_extractor.exe with good results:

when I add this to Home Assistant i can get this error message:
Config entry ‘rockrobo.vacuum.v1’ for xiaomi_miio integration not ready yet; Retrying in background
What i did wrong?
The installed version is Home Assistant 2023.2.2 (docker)

I wonder the same as @codahq . My S5 integration seems to need reloading every so often. Seems no one else has chimed in on this possibility yet.

I discovered what my issue was for anybody interested. It was not a region issue.

In my case the integration did not correctly pick up an IP address change for the device. I did not have a static IP address set. At some point my DHCP server gave the device a different IP address and the integration lost track and didn’t update.

The are ways to handle this I believe in the integration. There is an issue for this as well in the github.
The last time I checked in with the issue there was talk of handling it in the integration.

As for me, I fixed it by assigning a local IP address from the DHCP server. Since I have done this I have not had to reload the integration again.


Thanks for this! I had the same problem, recently made some changes on the network that caused the Vacuum that otherwise had the same DHCP lease for a while to change IPs which broke the integration. I was able to find the IP the integration was expecting so I could set a reservation in .storage/core.config_entries