Can not connect externally with or without duckdns

Server: RPi 3 B+
OS: Hass.IO
Router Model: T3200M

I have been attempting to get DuckDNS working on my server, but am struggling to access it externally wether through DuckDNS or over http. Using the various guides that are in the wiki or on youtube iI havne’t been able to get it to work (even though DuckDNS was setup with no errors and port forwarding was done correctly).

Recently, I went back to the beginning, and started following this guide because of how it breaks down each step. When following this guide I can’t even get past step 13, which leads me to believe it’s a router/port forwarding issue, but I can not for the life of me figure it out. A port scan on my WAN IP shows 8123 as open! I have another media server that runs traefik over port 443 so i know port forwarding works, but just not for the HA RPi on 8123.

I am fresh out of ideas and looking for help, Thank You.

How about a port scan on your duckdns address?

It could also be that your ISP uses CGNAT. Which is a killer for DDNS.

Compare your router’s public (WAN) IP address to the address reported by whatsmyip. If they are the same you are good if not your ISP uses CGNAT.

I was able to ping both my WAN IP address and my DuckDNS address, they both responded. A port scan of both also shows that 8123 is open.

My router shows the same IP address as is reported by I also run another separate media server that uses a domain name I own, so I know that the IP I used should work, as well as port forwarding various ports for that box.

Could this be an issue with the Pi rejecting external requests somehow? This is bizzare since I used a HassOS image, which I assume would just work??

Thanks for your help so far! Does anyone have any other ideas?


Are you attempting to connect from inside your own network? Does your router support hairpin Nat?

So I was just about to write up a post about how “I have tried that already”… but I did it once more just in case… and it (sort of) worked… then I saw I was on Wifi. I have attached a picture below of what I get; The Home Assistant log-in page (in Chinese for some reason) with an Error in red saying it has problems showing up. I pulled out a tablet I have and I still couldn’t access HA but when turning on a VPN I was able to access it fully without errors. Weirdly enough, when I turn off Wifi on my phone I suddenly have problems accessing it again. Not sure what that is about as my Wifi and Cell providers are different companies.

I assume this means NAT Loopback is not supported. I have seen posts about using DNSMasq to get around this, but does this also mean that DNSMasq would need to be the internal DNS server for all of my devices that I want to use to access the HA inferface?

Yes, I have all devices on my lan use pi-hole as dns server and dhcp server. This gives me access to all my lan devices by name, as well as the ability to do what you seek. Pi-hole uses dnsmasq.