Can not connect to the local server from Home Assistant app

I have installed the Home Assistant os on virtualbox in win10 and have done all of the configurations,
when I ping the server from windows cmd, it is ok. But when I browse http://homeassistant.local:8123/ in my browser or the Home Assistant app I can not connect to the local server.
There is no error, just it is waiting in the Preparing page.

Please help me out.

Whats the IP of the Virtual Machine?
Have you tried accessing it with the IP ( instead of the hostname homeassistant.local)?

Yes I have tried it using the IP. (
Recently I tried VMware Workstation and ran the server on it, this time I could connect to the server from my browser. But still can not connect using the app.
I have tried connecting to the same network on both laptop and app; I even hotspotted the laptop internet and connected to it with my phone but still can not connect the app.
I get the net::ERR_CONNECTION_TIMED_OUT error
Note: Using the VMware Workstation, the IP is