Can not delete todo item automatically, but why?

have this auto created

      - service: input_text.set_value
          entity_id: input_text.todo_afvalwijzer
          value: >
      - service: todo.add_item
          entity_id: todo.huishouden
          item: &item
              Saver: {{trigger.calendar_event.description}}
          description: &description
             Opgelet: {{trigger.calendar_event.description}} aan de straat zetten.
          due_date: &moment

todo item:

which is supposed to be deleted running this script:

    mode: restart
      - service: input_boolean.turn_on
          entity_id: input_boolean.afval_staat_voor
      - condition: numeric_state
        entity_id: todo.huishouden
        above: 0
#       - >
#         {{states('todo.huishouden')|int(-1) != 0}}
      - service: todo.remove_item
          item: >
            Saver: {{states('input_text.todo_afvalwijzer')}}
          entity_id: todo.huishouden

and which indeed runs fine to the final remove_item action.

it then returns this cryptic error in the logs:

Logger: homeassistant.components.script.reset_afval_buiten
Bron: helpers/
integratie: Script (documentatie, problemen)
Eerst voorgekomen: 7 mei 2024 om 23:26:57 (2 gebeurtenissen)
Laatst gelogd: 07:54:10

reset_afval_buiten: Error executing script. Unexpected error for call_service at pos 4: No existing item with uid/recurrence_id: db8a9fc2-0c8a-11ef-adc4-00ce39d11846/None
reset_afval_buiten: Error executing script. Unexpected error for call_service at pos 4: No existing item with uid/recurrence_id: d283922c-0cf7-11ef-adc4-00ce39d11846/None
Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/helpers/", line 501, in _async_step
    await getattr(self, handler)()
  File "/usr/src/homeassistant/homeassistant/helpers/", line 736, in _async_call_service_step
    response_data = await self._async_run_long_action(
  File "/usr/src/homeassistant/homeassistant/helpers/", line 699, in _async_run_long_action
    return await long_task
  File "/usr/src/homeassistant/homeassistant/", line 2738, in async_call
    response_data = await coro
  File "/usr/src/homeassistant/homeassistant/", line 2779, in _execute_service
    return await target(service_call)
  File "/usr/src/homeassistant/homeassistant/helpers/", line 975, in entity_service_call
    single_response = await _handle_entity_call(
  File "/usr/src/homeassistant/homeassistant/helpers/", line 1047, in _handle_entity_call
    result = await task
  File "/usr/src/homeassistant/homeassistant/components/todo/", line 519, in _async_remove_todo_items
    await entity.async_delete_todo_items(uids=uids)
  File "/usr/src/homeassistant/homeassistant/components/local_todo/", line 177, in async_delete_todo_items
  File "/usr/local/lib/python3.12/site-packages/ical/", line 230, in delete
    raise self._exc(
ical.exceptions.TodoStoreError: No existing item with uid/recurrence_id: db8a9fc2-0c8a-11ef-adc4-00ce39d11846/None

so, I figured it would be wrong syntax or so, and tried to do the removal from within the services page:

so, still an error, and its the exact string in the name field.

I tried searching for the todo item, but in States it only finds this

I am not sure if the item should have been listed there? If so, that would explain the error, but it wouldn’t be possible given the fact I have the actual item in my todo list…

any hints on how to debug this would be appreciated

i don’t see an obvious issue. but test a hypthesis for me… if you create a new todo list… give it a new entity name and try this exact same thing, do you get an error?

it gets even weirder:

there is this item in my todo list:

but when I try to tick the box it throws an error as you can see below.

selecting the time itself to get to the more-info:

is even weirder because then it also re-states the time does not exist!!

How can the system/frontend say the item does not exist, when I actually can see it there and click it.

Opened an issue at Can not delete todo item automatically: item does not exist · Issue #117163 · home-assistant/core · GitHub