Can not install home assistant on raspberry pi 4

Ok I am seriously frustrated already. OK I bought basically everything recommended from tutorial. I bought a raspberry pi 4 and card reader and 64GB memory card. I flashed the 32bit Pi image onto the memory card. Installed it in the raspberry pi 4 and hooked up to lan directly, powered on and nothing. I see no lan activity light and can’t find it anywhere on network and http://homeassistant.local:8123 doesn’t work. Any ideas on what to try next?

Can you connect a display to the pi HDMI port?

What are you using to power the pi?

What LEDs on the pi do you see? And are they flashing or solid?

I bought the recommended power supply with USB-C to power the pi, I do not have a micro hdmi cord to connect to pi at moment and the pi has a solid red led with green led flashing 4 times continuously.

Ok, which version of hassio did you put on the sd card specifically? Could it be that you (by accident) downloaded the image for the RPi3b instead of the one for the RPi4?

1 Like

I imaged this file hassos_rpi4-3.12.img to SD card with balenaetcher. It’s the raspberry 4 32 bit image.

Ok, that is weird then. FYI the 4 times green led means that the RPi4 is booting from it’s eeprom, but it can’t find the necessary start.elf file on the SD card. So either there is something wrong with the image, or with the SD card. Do you have an old SD card to rule out this card?

1 Like

I guess i can try an older SD card. The card does read with the COASD Memory Card Reader in a my laptop and desktop

You could also try the raspbian buster lite image from raspberry pi itself to check if that works.

1 Like

I got the same problem few weeks ago. I solved it be using a different sd card.

wow, thanks. I tried an older SD card and it works now. Thank you.

1 Like

Now you can format again the new SD card and try again

Did you buy the card from eBay ?

I have bought ‘cards’ from ebay that ‘appear’ legit, but do not pass the read write speed tests with decent speeds.
I now buy ony from a seller I have dealt with many times before who has never let me down (satiety memory). Try running a speed test (many available on Internet but crystal works for me) then contacting the people you bought it from if it doesn’t pass muster (should be greater than 20Mb/s both ways on usb 2.0)

1 Like

i have the same issue. raspbian works fine, home assistant doesn’t. no matter which sd card i’m using.

FWIW, I had the same problem with hassos. I tried with 2 different SDcards, both of which had passed write/read tests [f3] to no avail. Problem was solved by installing Raspbian Buster, then Home Assistant Supervised, which works fine. I guess I did something wrong with hassos but happy with the outturn.

I’m also having exactly the same issue, and tried 2 SD cards. Raspbian works fine.

If you have Home Assistant Supervised are you able to install Apps and access the app store?