Can one trust Home Assistant, since integrations tend to break so often?

I have quite a few integrations in home assistant, Tuya, Volvo, Spotify, and quite a few more.

However, they tend to break every other week or so, and now, most of them have stopped to work.

Is this the expected behavior of Home Assistant? Initially, I was quite happy to use it and it offered a lot of home automation. However, now it is rendered useless. Am I the only one experiencing this?

It is not Home Assistant - it is the integrations.

I have a few integrations and, over the past 4 years, only one has “broke” (which I was able to fix with a workaround until the next integration patch was released).

If things are breaking for you, ask here about how to get it working again. And there is also a link on each integration page to view know issues.

You can also provide feedback (log issues ) to the integration developers.

thanks for the comment.

Yes, I understand the steps, etc. But if the integration break every week, how should the system be maintained. It can hardly be meant to sit daily and survail it?

Following are broken:


To fix and follow the steps for each one of them takes quite some time.

I would start by looking at the logs to understand why they are breaking.

Also, all (except dlna) require a connection to the internet (they are cloud based). Perhaps it is not the integrations but a unreliable connection to the internet. Just a guess - I really don’t know - the log files may have more info.

1 Like

I do have quite a lot of those types of errors, but the rasberry has internet connection. returned error ‘ClientConnectorError’

aiohttp.client_exceptions.ClientConnectorError: Cannot connect to host ssl:default [Try again]

and similar. And I can access home assistant from other computers and through vpn from externally

I use SMHI and it works fine.
What is the issue?

Tuya… well yeah… it could be better for sure. But add the local tuya integration and most of your issues will be fixed.

Home connect is really bad. ( But so is the home connect API, so you can’t really blame them too much.)
It needs to be reloaded every now and then to work.
But there is home connect alternative in HACS, that is very stable and fast.

I don’t use the other so I can’t help you.
But most of the time you just need to reload an integration to make it work again.
You can even make an automation that reloads integrations that is most problematic.

Sounds honestly like you have NetWork issues, can’t hardly blame HA for that

Instead or Posting/Open a Topic with that rant Header !, you should be serious about your Installation, and check up on your Logfiles Errors, and Open a topic for help … if you get any after this kind of Topic

Please Read Below, so you have a chance of getting serious Answers/Help

How to help us help you - or How to ask a good question.

36 integrations here…and no real issues here for the last 4 years. I did have to adjust some every now and then, but i always read the release notes, so i was prepared.
I use LocalTuya, never failed me.

Anyway, supported integrations should not fail (and for sure not often), again, read the release notes before updating….

With custom integrations (like from HACS). well. they are custom and not maintained by HA. but only their developer(s);it is up to them to maintain it (if it is still maintained).
I am saying that because have also written a custom integration myself, and ffor now I can still maintain it, but next i will probably need to abandon it, as I will move and will no longer have the device (pelletstove), so i won’t be able to trst anything on it anymore.

Anyway, the advice is, try to minimize the amount of custom integrations. :thinking:

1 Like

Thanks for the hints, i’ll try and look into it from that end. Have tried restoring backups and reboots, etc.

You need to post relevant Errors, from when they start to occur, also describe your HA and Network setup, i.e http/https, proxies etc etc

The errors you showed above, is as they state Connection Problems, nowhere it states the various Integrations is corrupt or broken !

Ohh and Please change your Topic Header, you give people negative Vibes , And that’s not what they are here for ! :slight_smile: :wink:

If I were in your position, I would cut my losses and find another smart home system.

Can one trust Home Assistant, since integrations tend to break so often?

That’s a very loaded question. “tend to break so often” is not my experience at all. And I have a lot of integrations.

In answer to your question,

Core integrations:

Yes. These are actively supported by the Home Assistant team and code owners.

Third party integrations:

Maybe. Depends on the developer. Some abandon their creations and these eventually break. Some just take a while to fix things because they are busy with work that they actually get paid for. Some are super pro-active and monitor the HA developer blog for upcoming breaking changes and release patches before new releases.

Before installing any 3rd party integration look at the developers github repository.

Are they actively supporting their creations?

Do the integrations have a lot of unsolved issues?

One way to encourage 3rd party developers is to actively help them.

  • Submit PRs to fix things if you are capable.
  • Answer issues with known solutions so they don’t have to waste time doing this.
  • Make a donation if you can afford it and find their work useful. Even a small donation helps if many people do it. Keep in mind this is entirely voluntary and does not entitle you to anything.

Wow, something is REALLY off with you system!
Can one trust Home Assistant?” → YES, definitely.

You registered about 2 months ago but this is the first time you ‘ask for help’.
Good that you finally took the plunge and as already stated: provide some info to be able to help you.

I’m not sure core integrations get better support than custom integrations.
Looking at the issues with generic thermostat there is very little happening.
Issues are open for years and no comments at all from developers.

Hi Hellis81,

I did have the same problem with my home connect device, a Bosch dishwasher. It lost connection to the official APP and HA again and again.
The clue, for my setup. I created a special WIFI 2G SSID with no roaming, only working form one of my access points, disallowing “optimise channel”.
The device is, for some reason, not able to understand roaming between access points, or access point which change channel. Then it loose connection.
Mine is solid now, even when we had a power failure it came online again.

I don’t have any issues with downtime.
That part works.
The issue is that the official integration needs to be reloaded every now and then.
I can look in the Bosh app and it works fine, the HACS alternative integration works fine, but the official integration has stopped.

The alternative has worked very nicely for me, much quicker and has only failed me once so far.
Not sure why that was, but it could be because of a reboot that happened at the exact wrong time.