Can only access configuration page from host machine

Fresh install of HA in a Docker container on Ubuntu 22.04.4 LTS. Besides the time zone and config folder settings, did not touch the setup command from the instructions at all. I can access the configuration page just fine on the host machine using loopback IP, internal IP and internal hostname (with or without “.local”) on port 8123 just fine, but I cannot access it from any other device using those same addresses (obviously not the loopback address because duh), I just get timeout errors.

There seems to be no network issues on HA’s end: it found a bunch of devices on my network, it looked up my address just fine and I connected to one of the integrations via API key; it can very much talk to things internally and externally. What’s slightly weird is that the HA Android app found my server broadcasting on the internal IP, but of course it times out trying to connect to it (error -8).

I went into the advanced network configuration and set the local IP and port just to be sure. Network adapter is set to auto and it’s on the one Ethernet port this machine has and it’s reporting the correct local IP. netstat (outside of Docker) shows port 8123 bound to python3, which was spawned by the process that is running HA in Docker (stopping the container and re-running netstat shows nothing on that port). System is also running pi-hole and I can reach it’s config page just fine on port 80. Downloaded full log is completely blank, log.1 file only shows something about a session closing on an MQTT device, Docker log below but it says nothing as well unless exit code 100 is something besides “everything’s A-OK”.

None of the other threads I found regarding not being able to reach the config page seems to apply here, hence the new thread. Hope you all can help me figure this out.

s6-rc: info: service s6rc-oneshot-runner: starting
s6-rc: info: service s6rc-oneshot-runner successfully started
s6-rc: info: service fix-attrs: starting
s6-rc: info: service fix-attrs successfully started
s6-rc: info: service legacy-cont-init: starting
s6-rc: info: service legacy-cont-init successfully started
s6-rc: info: service legacy-services: starting
services-up: info: copying legacy longrun home-assistant (no readiness notification)
s6-rc: info: service legacy-services successfully started
2024-07-08 20:38:23.375 ERROR (MainThread) [pylitterbot.ws_monitor] LitterRobot4 Session is closed
[03:38:24] INFO: Home Assistant Core finish process exit code 100

I am not much into docker myself, but I know you have to set up ports to be used.
Normally HA is running with the host option for port setup.

That is what the install command in the tutorial specifies:

docker run -d \
  --name homeassistant \
  --privileged \
  --restart=unless-stopped \
  -v /PATH_TO_YOUR_CONFIG:/config \
  -v /run/dbus:/run/dbus:ro \
  --network=host \

Was able to fix the issue thanks to this Github post, just needed to change the port to 8123.

Hi, welcome to the forum!
Good you found a solution for you issue!

Please take the time to mark the solution as the answer, you do that by selecting the three dots under the post:


Then select the check box:

By doing so this can be useful to other users as well and prevents that someone else steps in and still tries to help you.