Can ping my HA but can't access GUI

Running HA OS on a little dell tower.

This happened about a month ago too when I wasnt home of course. Wife said we lost power and when power came back on, HA wouldent load, she couldent access the app on her phone. When I came home, I took the computer its running on and connected it to a monitor and everything looked normal and then of course it all worked.

Well today, it happened again when I was home. My old wyze integration stopped working so I rebooted HA. Since then, its never come up. I can see it on the network, I can ping it. I can prove the IP is for HA because if I disconnect the ethernet cable going to computer, ping fails.

But I can not acess the GUI either using the IP or homeassistant.local. And even if its a local network issue (which is not), if HA was still coming up, all my Zwave/zigbee devices should still work.

If I plug the computer its running on into a monitor again, what should I be looking for? What commands should I run?

Here is video of bootup when I connect it to monitor. Oddly, I can go to the Observer address and I get Connected, Supported, and Healthy. But try to go to 8123 and no go, and as I said, no zwave/zigbee devices work.

ha core rebuild

ha su repair

rebuild errors out "Another job is running for job group home_assistant_core.

repair completes but didnt help.

Did you ping homeassistant.local or 192.168.86.200?
The 192.168.86.200 address looks suspicious. What is the IP of your router and PC?
If you installed Home Assistant on a virtual or container, I can’t help you since I run my HAOS on a dedicated Intel NUC.

Z-Wave and Zigbee are their own network. The integrations give you the ability to integrate the devices into your Home Assistant (automations, for example).

But I can not access the GUI either using the IP or homeassistant.local. And even if its a local network issue (which is not), if HA was still coming up, all my Zwave/zigbee devices should still work.

I misread your OP.
You may be sure it isn’t a network issue, but you haven’t provided any evidence that it isn’t. As I said, the 192.168.86.200 address looks suspicious.

So, again, what is the IP of the router and your PC?
Also, how is Home Assistant installed?

1 Like

Are you using a Google Wifi router? If not what’s the brand. I agree with @stevemann that the IP is suspicious.

If possible, have you connected the HA device directly to your router?

Do you have a router connected to the internet via a modem/router?

Why are you guys so hung up on the IP address? I’ve used the same IP for 3 years. Its a static IP, its reserved in my router for HA. I do not have google wifi. I am directly connected to the HA computer.

Can either of you explain how, even if it was an IP issue, that the rest of HA wouldent come up and all of my non-ip related add-ons, integrations, sensors, etc, would fail to work? Because I have lost network in the past, and, as I said in my original post, all my zwave and zigbee devices still work.

Am I missing something? I kinda feel like twilight zone right now.

Now I am confused. Do they work, or not ?

I said they all work in context of in the past when I had lost IP network (“because I have lost network in the past…”)

Right now, nothing works. Other than HA gets its static IP thats its been getting for 3 years.

I agree, there is nothing suspicious about this IP, other than that the 192.168.68.0/24 isn’t as much used by default as for example 192.168.0.0/24. I assume your other devices has IPs in the same range.

this is a very curious case… at least so far. i can understand the initial curiosity about the ip address… ..68.* is uncommon for most homes, and some systems (e.g. windows) will generate such a ip address if it failed to get one from dhcp. clearly this is fine in your case, but i can understand why folks had initial questions… but… moving on…

  1. do you have backups?
  2. do you have samba installed? can you access it in a more easily managable way?

one thing i’d start doing if possible is to try booting from a clean config files… but make sure you have backups.

What does info show you on the console? Is HA showing as frozen or running? From your original post you say that the ping succeeds, but the GUI fails, which implies that HA is not fully started. The fact that your Z-Wave and Zigbee also doesn’t work all points to HA being hung up.

You also mention that things go haywire with your Wyze restarting. It makes me wonder if the order of the startup might be a problem, is the Wyze providing any network services at all?

Do you have SSH access to this device? Or, as asked earlier, Samba? If so then you might be able to do some additional diagnostics that way, especially from SSH.

We don’t know your system configuration.
We don’t know how long you have been using this configuration.
We don’t know your experience level.
Your original post screams “network”.
We don’t know these things so we either have to guess or ask you a lot of questions.

The reason that we (at least I) harp on the IP addresses is because we’ve seen this before. It’s almost always been a network issue.

Have you tried rebooting the router?
Can you ping other devices on the network?
What is the IP of the router?
Did you ping homeassistant.local or 192.168.86.200?

Finally, you never did say how is Home Assistant installed?
Virtualization and containers do weird things with networks that I have no experience with. If you had said "Container XYZ on a Raspberry Pi " in your OP, I would have never offered my experiences.

You have not provided enough data to tell us that your problem is not a network issue.

No, windows will generate an IP address that begins with 169.254, which is called an APIPA address.

2 Likes

Thanks for all your help Steve, but I think I’ll move forward with others who, when presented with the same data as you, agree with silly ole me, that its not a network issue.

Because if me saying I can ping it and then when i disconnect the cable i cant, doesnt “prove” to you network connectivity whether that be me using IP or name and me also stating MY experience that when I have had IP issues in the past, the core home assistant functions related to zwave and zigbee still work even though I cant access the GUI, then its your own stubbornness and insistence that because last time it was a network issue when someone couldn’t access the GUI, that it MUST be my issue too, regardless of what I say and what my past experiences (stated very clearly in my OP) are.

You can respond and get the last word; I’ll be moving forward.

I agree, it appears HA is not fully starting. Starting enough to get network, but not enough to really fire up anything else.

With the wyze, its the old school v2 stuff. It works great and then maybe once a month, receiver will stop working/communicating with HA, and I have to cycle power.

I have tried booting up without anything other than network cable connected (to try to access the GUI) and it hasnt helped. But see below after my response to @armedad

I do have backups. I do have Samba I believe, but have not had to use it much so not very familair. Also with backups, is there a way in CLI to restore from one? I am not proficient at all with CLI in HA.

So after 10 power cycles, the GUI finally came up…kind of. I had some weird alarms. Zwave started, but Zigbee wouldent. The zigbee2mqtt add-on kept erroring out. Then after maybe 2 minutes, I couldent access the GUI anymore. And I was back to where I started.

My question is, if theres some type of underlying corruption that occured and I do a fresh new install of HA OS and then revert to my backup. Will the backup bring back that corruption or is it more just settings? I have NOT changed anything setting in the past 2 weeks. I am 100% positive of that, so I know its not a setting that caused the issue.

Take a backup immediately. Install SSH before you do that so it comes with the restoration. You may need to restore.

You never answered this, it could shed some light. Next time it bombs please do this so we know the state of HA at that point in time.

using samba is easy… it presents to your laptop as a unc path where you can edit your config files… go to \homeassistant.local\config from your laptop… if you get to that ha prompt, samba is usually loaded and working even if the front end isn’t.

to answer your question about backups, if you have one and want to do a full restore, i wouldn’t try to do it in the cli, i’d just cold boot the puppy and it’ll give you an easy button to restore the backup.

the reason i asked about backup and samba is that you could muck around with your config aggressively and restore individual files via samba if you wanted (e.g. restore the basic configuration.yaml and see if it is better and then add back bit by bit… but honestly it sounds more right now like some sort of database corruption w/ z2m or mqtt.

it does have a high chance of restoring corruption if it was corrupted when backed up. the backup is just a tar file so you can see what is restored… you’ll see database backups in there…

The nice thing about also using SSH is that you can telnet in, which is a much smoother protocol during problems than Samba can be.

That being said, the restore will eliminate corruption of the core HA installation as a problem, leaving your config. With SSH / Samba you can edit your config to see if you can trace and eliminate the problem - at the very least you can view the logs or kill the database to see if that resolves the problem - you can always restore the database later. I would absolutely rename the DB and let it re-create it, if it all works fine then you found your problem.