Can someone help me get control of my UI again

I just upgraded from 0.80.x to 0.90.2 so of course now Lovelace has taken over. But I am lost on how to manage it. My interface still looks the same as before I updated but when I try to add items to groups.yaml nothing happens. So I started trying to research how to manage the UI.

I watched a video on how to manage the UI and it says I can just edit directly in the browser by clicking on the menu and clicking on “Configure UI”. When I do that I get a warning that I am taking control and can’t turn back.

Should I take control?
Can I still manage my UI from files or do I have to use the editor now?

I tried reading docs and watching videos but they don’t seem to match what I am seeing. I guess this stuff is getting changed so quickly it’s hard to keep up.

I am just looking for point in right direction.

You can either use the ui or files, not really both (although some people use files and paste into an editor provided by the ui). Neither option is irreversible, so you can have a play.

Anything you do in the ui is available as text in the raw editor so if you decide to go to manual mode you can copy anything you’ve done to your ui-Lovelace.yaml.

You can still do it the old fashioned way with groups if you prefer that method.

So to your user page and go to ‘enable states UI’ and then refresh the page and it should be back to how it was before you updated, UI wise.

I have two instances. One at work and one at home. I upgraded my work instance a few weeks ago but couldn’t find a way to switch back once I clicked on “Take control”. How do you switch back to letting home assistant manage the ui?

I don’t even have a ui-Lovelace.yaml file. I don’t see any way to mange the UI in the current mode. Changing my yaml files doesn’t do anything and there is no editor interface. I am guessing I should just click on “Take Control”

I don’t see this option. Not on users page (that seems a strange place to find it). Not on any other configurations page.

Perhaps you guys are using I am using hassbian, I thought they were same but maybe not.

if you put

  mode: yaml

into your configuration.yaml and reboot you can then create and edit a ui-lovelace.yaml. It’s in the docs.

I had done that on my work instance and there was a lovelace.yaml file for that instance but when I upgrade to 0.90.2 the file stopped working.

My understanding is that when I upgraded to 0.90.2 on my home instance lovelace became the default ui.
It’s documented in the 0.86 release notes.

So without the lovelace: entry in my configuration am I NOT using lovelace yet. I thought it was the default now. My ui control yaml files don’t seem to work anymore so I figured I was in lovelace mode.

OK, I took control and the editor seems easy enough. Thanks for the info.

I don’t see this option. Not on users page (that seems a strange place to find it). Not on any other configurations page.

I ckecked again and the option is actually on the ‘dev-info’ page on the developer tools, the right most icon with the i in a circle.

It’s the page with this info:

Home Assistant

Path to configuration.yaml: /config

Developed by a bunch of awesome people.

Published under the Apache 2.0 license
Source: server — frontend-ui

Built using Python 3, Polymer, Icons by Google and

Frontend JavaScript version: latest

Go to the Lovelace UI

You should have :Go to the States UI

Thanks, never would have found that. Well hidden :slight_smile: It should be on a configuration page.

Sticking with Lovelace for now since I figured out how to control it now.

No problem glad you’ve got your GUI under control. :slight_smile:

I think themes, ui and other frontend stuff it all tucked in the user profile section, I agree it would be nice to have it in normal config instead.