Can’t connect to home assistant in local network

Hi guys,

I have a problem with my Home Assistant, for some time now this problem has been occurring, I try to access the Home Assistant via http://homeassistant.local:8123 but it tells me that it is impossible to access the site, either from PC or app.

If I unplug the power to the raspberry and reconnect it it works again for a day.

I will preface this by saying that I am not very experienced, I have a Raspberry Pi 4 Model B 2GB connected via ethernet to the modem and by my choice it works locally, I am you can access HA outside the network.

I tried to search for a solution and found similar cases but not the solution.

Excuse my English, but it is not my native language.


Although you can’t access the web interface, are your automations still running?

In other words: has HA completely crashed?

Try to connect to home assistant using its ip address like
If this is working than you probably messed up something in dns resolver or host name.

I don’t have any automations for now, I use it to control the temperature and humidity and turn on the secondary lights in the house, if I look at the logs I don’t find anything strange

I just restarted it, when the problem arises I will try

I just tried it and it doesn’t work

You don’t have a static ip for your ha. Try to configure your router to assign a static ip to your ha. And ha to use a static ip.

the IP is static, it is the first thing i did

I run ha on debian 11. I can ssh to my server and run

sudo ha network info

It give me information on my ha ip address among other things.

It’s been a day that not that HA doesn’t give me the problem, I don’t know if it’s because I updated the Core to the latest version