Can´t connect to MQTT broker

Hi dear community,
I had a MQTT running which stopped working (after some issues with my network). So I decided to uninstall my mqtt integration and tried to add it again with a message “Unable to connect”. I always get the message in the logs below:

Traceback (most recent call last):
File “/srv/homeassistant/lib/python3.7/site-packages/homeassistant/util/”, line 20, in run
run_old(*args, **kwargs)
File “/usr/lib/python3.7/”, line 865, in run
self._target(*self._args, **self._kwargs)
File “/srv/homeassistant/lib/python3.7/site-packages/paho/mqtt/”, line 3428, in _thread_main
File “/srv/homeassistant/lib/python3.7/site-packages/paho/mqtt/”, line 1769, in loop_forever
File “/srv/homeassistant/lib/python3.7/site-packages/paho/mqtt/”, line 1071, in reconnect
sock = self._create_socket_connection()
File “/srv/homeassistant/lib/python3.7/site-packages/paho/mqtt/”, line 3509, in _create_socket_connection
proxy = self._get_proxy()
File “/srv/homeassistant/lib/python3.7/site-packages/paho/mqtt/”, line 3470, in _get_proxy
if self._proxy_is_valid(self._proxy):
File “/srv/homeassistant/lib/python3.7/site-packages/paho/mqtt/”, line 3459, in _proxy_is_valid
return check(p.get(“proxy_type”), p.get(“proxy_addr”))
File “/srv/homeassistant/lib/python3.7/site-packages/paho/mqtt/”, line 3456, in check
t in set([socks.HTTP, socks.SOCKS4, socks.SOCKS5]) and a)
AttributeError: module ‘socks’ has no attribute ‘HTTP’

The sudo lsof -i tcp:1883 tells me that my shellly devices are connected properly:

mosquitto 400 mosquitto 5u IPv4 11147 0t0 TCP *:1883 (LISTEN)
mosquitto 400 mosquitto 6u IPv6 11148 0t0 TCP *:1883 (LISTEN)
mosquitto 400 mosquitto 8u IPv4 360696 0t0 TCP home.lan:1883->shellyswitch25-98F4ABF2C016.lan:42669 (ESTABLISHED)
mosquitto 400 mosquitto 9u IPv4 14323 0t0 TCP home.lan:1883->shelly1-BA4108.lan:31136 (ESTABLISHED)
mosquitto 400 mosquitto 10u IPv4 368369 0t0 TCP home.lan:1883->shellyswitch25-B945A1.lan:16424 (ESTABLISHED)

I also confirmed that publishing/listening works properly. The MQTT broker is running on the same RPI as my homeassistant. I have done several restarts without any success.
Any hints are much appreciated
Best regards

How did you configure mqtt ?

Just installed mosquitto without any additional .conf files. No username and password required.
Is that answering your question?
This is the entry of my mosquitto conf file:

pid_file /var/run/

persistence true

persistence_location /var/lib/mosquitto/

log_dest file /var/log/mosquitto/mosquitto.log

No additional files in /etc/mosquitto/conf.d

No. I wanted to know how you configured mqtt in HA.

I use the MQTT integration from the integrations page. I enter the MQTT broker address ( which is the local IP of my RPI), do not change the port field and leave the username/password blank.
After pressing submit I get the spinngin wheel followed by “unable to connect” message within the configuration/setup window.

I did an upgrade to 0.100.5 which fixed the issue. Still not sure what the problem was exactly.