Can’t get Node-red to control devices or entities

I have been trying to get my first two sequences to work for the last three days. I am simply trying to have Honeywell light switches turn on lights when motion detected (Aeon Multi & Zooz outdoor motion). I have no idea why it isn’t working. when I run a normal automation in HA, it works (lights come on). Any help would be very much appreciated.

You’ve given us no information that would enable anyone to help you.

  • What have you tried (post your flow)?
  • In what way is it not working?
  • Do you get any error messages?

HAHA, excellent point. Sorry about that. Below is an error I get when I use the “inject” node for one of my automation: “Call-Service attempted without connection to server.” Attached please find the screenshots of the “sequences” and “properties” of one of the nodes that the error seems to be occurring in. I am getting the same error (I think) for both sequences, so I am inclined to think it is occurring at the Switch (Call service) node. Thanks again, for your reply and for any help.

Here is the code for the first sequence:
‘[{“id”:“f683b152.66e6c”,“type”:“api-call-service”,“z”:“e10a53ca.d6cb58”,“name”:“Turn on laundry room light”,“server”:“dc687f53.d0afa”,“version”:1,“debugenabled”:true,“service_domain”:“homeassistant”,“service”:“turn_on”,“entityId”:“switch.honeywell_39348_zw4008_in_wall_smart_switch_switch”,“data”:"",“dataType”:“json”,“mergecontext”:"",“output_location”:"",“output_location_type”:“none”,“mustacheAltTags”:false,“x”:460,“y”:420,“wires”:[[“7b949e5b.35cbe”]]},{“id”:“7b949e5b.35cbe”,“type”:“debug”,“z”:“e10a53ca.d6cb58”,“name”:"",“active”:true,“tosidebar”:true,“console”:false,“tostatus”:false,“complete”:“payload”,“targetType”:“msg”,“x”:710,“y”:460,“wires”:[]},{“id”:“ac5e7b47.3560e”,“type”:“server-state-changed”,“z”:“e10a53ca.d6cb58”,“name”:“Laundry room light on”,“server”:“dc687f53.d0afa”,“version”:1,“exposeToHomeAssistant”:false,“haConfig”:[{“property”:“name”,“value”:""},{“property”:“icon”,“value”:""}],“entityidfilter”:“binary_sensor.aeon_labs_zw100_multisensor_6_sensor”,“entityidfiltertype”:“exact”,“outputinitially”:false,“state_type”:“str”,“haltifstate”:“8”,“halt_if_type”:“num”,“halt_if_compare”:“is”,“outputs”:2,“output_only_on_state_change”:true,“x”:160,“y”:420,“wires”:[[“f683b152.66e6c”],[]]},{“id”:“dc687f53.d0afa”,“type”:“server”,“z”:"",“name”:“Home Assistant”,“addon”:true}]’

I am very new to all of this. If there is more information needed please let me know and I will provide. Thanks

Domain should be switch instead of light.

Data should be {“entity_id”:“switch.honeywell_39348_zw4008_in_wall_smart_switch_switch”}