Can’t get second Ikea Rodret paired with ZHA

Hi, the first Rodret I paired with ZHA worked perfect and have automatons setup to turn on and off my living room light, I had 2 other Rodrets and I cannot get them setup properly, I have tried repairing and reconfiguring countless times and it sometimes even says it’s all setup, but every time the buttons don’t do anything in HA. With the first one I thought it could be a faulty device even though it was seen by HA, but with the other one not working properly either I’m not so sure. Any ideas please as I’m going mad trying to work out what’s wrong as I don’t really have much in-depth knowledge of how this stuff works and how to debug this stuff, it should just work right?

Could you be more specific? Can you show us what you are expecting (as in your original Rodret, presumably) and what you have actually got?

Perhaps start with a screen shot of the Device Info pages?

Thank you for replying.

I’ll try and explain but it’s all feels a bit hit and miss at the moment. Just for a bit more background I’m running HA on a raspberry pi and have a SONOFF Universal Zigbee 3.0 USB Dongle Plus Gateway. One of the two which I left in a broken state just started working properly the next day. The other one I’ve still not had luck with, it’s the same routine over and over again, I start pairing and it usually doesn’t get past this screen the logs are like this:

Unknown device AddrModeAddress(addr_mode=<AddrMode.NWK: 2>, address=0x9926)

Unknown device AddrModeAddress(addr_mode=<AddrMode.NWK: 2>, address=0x9926)

Unknown device AddrModeAddress(addr_mode=<AddrMode.NWK: 2>, address=0x9926)

[0x9926:1:0x1000]: Couldn’t get list of groups: Request failed after 5 attempts: <Status.MAC_NO_ACK: 233>

[0x9926:1:0x1000]: Couldn’t get list of groups: Request failed after 5 attempts:

And it just keeps going.

I then try and reconfigure and usually get this Broken reconfigure screen - Album on Imgur. A working device screen looks like this: Working Dimmer - Album on Imgur and a incompletely configured one will look like this Not working dimmer - Album on Imgur

I then factory reset the rodret and try again over and over again. Sometimes it will get a bit further and tell me it’s setup but the buttons still won’t register in HA. I have also tried pairing it directly with an Ikea bulb and it works fine!

All those type of symptoms are common indicators of EMI/RMI/EMF-interference and/or poor reception.

The first thing you need to know is that all Zigbee radios can be extremely sensitive to EMI/RMI/EMF-interference, and the second thing you need to know is that a Zigbee network’s range/coverage depends heavily on mesh networking by design because Zigbee radios use low-power and high-frequency radios have very week signals with poor propegation (crappy penetration of building materials). Those two combined can create the perfect storm, so you really need to take preventive actions to both avoid placing Zigbee devices too close to sources of EMI/RMI/EMI. Read and follow these best practices:

The most important preventive actions to take mentioned there is to connect the Zigbee Coordinator via a long shielded USB extension cable to a USB 2.0 port of USB 2.0 hub and keep it away from USB 3.0 devices/peripherals/cables, and also add many always-on/always-connected/always-powered mains-powered Zigbee devices at strategic locations in your home that act as “Zigbee Router” devices (sometimes also referred to as Zigbee Range Extenders or Zigbee Repeaters).

Other than that you as well need to replace batteries with fresh ones in any battery-operated devices.

If and when followed all advice try re-pairing the device again before doing any deeper troubleshooting.

Only then can you expect it to “just work” :wink:

So after if you still have problems after that then it is probably either a bug and/or a faulty device.

Also suggest try upgrade to the latest unofficial community Zigbee (NCP) firmware build on your Zigbee Coordinator radio adapter, nothing that there are two different Sonoff Zigbee 3.0 USB Dongle Plus models (“ZBDongle-E” based on Silicon Labs EFR32MG21 radio SoC and “ZBDongle-P” based on Texas Instruments CC2652P radio SoC) that uses different firmware builds:

Thank you, there is a lot to process here, will reply as soon as I have had time to read through this properly!

Plugged in a long USB cable tested it in a different position and it all seems to work now! Thanks for all the info very useful!