Can´t pair any Zigbee devices


My problem started with one motion sensor RTCGQ01LM not detecting movement in the usual time or not at all. So I thought maybe the batteries were dead and changed them. After that it didn’t do anything. So i tried repairing. It did not pair. Then i took another sensor RTCGQ11LM. Also don’t work. Gave them to my friend who confirmed that his system pairs them normally. Then I thought maybe my Zigbee adapter Texas Instruments LAUNCHXL-CC1352P-1 is the problem. Got one workin unit from a friend and changed the ieee and so on and still the same. Now I have tried different devices and nothing is pairing. I have about 35 xiaomi aqara devices working but if I try to repair any of them then they will not work anymore.

So here is what i have tried:
With zigbee2mqtt I have tried reflashing the coordinator firmware on 5 different machines. I have tried a fresh install with 2 different Texas Instruments LAUNCHXL-CC1352P-1 adapters.
I tried a fresh install and ZHA with conbee II adapter.
Nothing has worked!

Today i taught that maybe is something wrong with my devices and took my xiaomi gateway. Everything pairs like it should.

The are no errors in logs.

I also made a thread zigbee2mqtt github:

My coal here is to get zigbee devices pairing again but i really don´know what to do anymore.

I did get it working with conbee II. The problem was that i did not use an extension cable. But with Texas Instruments LAUNCHXL-CC1352P-1 adapter that i used for years i can´t get it to work anymore. In Zigbee2mqtt github i got the info that the firmware is not flashing correctly and trie different machines. I tried 3 different windows machines, 1 ubuntu VM on unraid and Raspberri Pi OS on RPi 4 with no luck. I am not sure but i think that the problem has to be in the firmware. I can’t get older firmware to tri it out. Can someone help me with that?

#mqtt, #zigbe2mqtt, #adapter, #pairing, #firmware

If your RF environment is a bit noisy then should also take actions to avoid interference sources, see:


Then after working around interference and get it working also read these before starting pairing devices:


Thanks for your answer!

I have done all of these things and my system has worked for about 5 years and i have not had this kind of problem before.

I got the system working again with conbee 2 adapter and i also found older firmware that worked with Texas Instruments LAUNCHXL-CC1352P-1. I will try it out and let you know if it helps :wink:

The latest firmware does not suit for Texas Instruments LAUNCHXL-CC1352P-1 !
I got the Z-Stack_3.x.0 20210120 firmware and everything works without problems again. I hope that someone will fix this issue.

@soulman Report as new issue to → Issues · Koenkk/Z-Stack-firmware · GitHub

Koenkk (Can´t pair any devices · Discussion #11361 · Koenkk/zigbee2mqtt · GitHub)

It was never the intention for these fws to work on a CC1352P1, I only support the CC1352P2.

The Texas Instruments LAUNCHXL-CC1352P-1 has transmitting power for 2,4Ghz up to 5dBm but the LAUNCHXL-CC1352P2 has up to 20dBm. On the newer firmware the default is set to 9 dBm and this is the reason why it did not work anymore. I flashed the latest firmware and added the following to zigbee2mqtt configuration and now it works without problems again:

  transmit_power: 5

Sorry for the stupid question but where exactly did you add this as I’m getting the same issue with not being able to pair any zigbee devices (this used to work until about a month ago)

I added it to the add-on configuration :wink: