Can’t remote access with Duckdns all of the sudden

Hi all, I previously set up remote access with Duckdns over 3 years ago and everything was fine. Then all of the sudden when I traveled recently, I realized I could not access it remotely.

I can still access using localIP:8123

But times out when I use

DuckDns add on is up to date and my account on seems to be all in order.

I also recently changed my router to Eero and did the port forwarding to 8123 but don’t know how to verify if it is working correctly.

Also my configuration.yaml file shows this ::

Loads default set of integrations. Do not remove.


Load frontend themes from the themes folder

themes: !include_dir_merge_named themes

automation: !include automations.yaml
script: !include scripts.yaml
scene: !include scenes.yaml

ssl_certificate: /ssl/fullchain.pem
ssl_key: /ssl/privkey.pem

Is this correct or is there something missing ?

Anybody can help me with debugging this issue ?

Does the IP address reported by the DuckDNS admin site (where you set up your domain) match the public IP address of your router?

Yes for both ipv4 and IPV 6. Previously IPV6 was blank and working

Do the DuckDNS add-on logs tell you anything significant?

Yeah I updated and restarted it a couple times and all come back green.

Is everything working now?

No. External connection does not work !

Please share the DuckDNS add-on log.

IPv6 is usually prioritized over IPv4 and your IPv6 might not be configured correctly.
IPv6 do not require portforwarding, but you need to have a globally routable address on your HA installation and your firewall need to be open for that traffic.

Thanks @WallyR for the info. Will check the setting as you suggested

Well this is good news and strange and embarrassing. As this morning, after leaving it overnight without success. It all of the sudden works.

Not sure if it is DuckDNS, or my Eero router setting. My Eero router seems like a lot of the settings are stored or done with the cloud, so may take longer to update, also maybe DuckDns also takes time to update the parameters. Embarrassing as I really do not know what changed and what was the solution, Only can think that something related to the settings in the cloud taking time to update.

At least maybe this info will help others having the same issues.

Thanks Guys

DuckDNS use the IP-address you connect from, so issues with settings have no effects, as long as you can connect to the internet.
You can check you public IP address on and that should be the same as the one your DuckDNS address resolve.